How can i use alpha blend on my hair without making weird patterns?

when I want to use alpha blend with showing backface there appears a weird pattern. It doesnt happen with alpha hashed but with alpha blend. Is it possible to use alpha blend without these weird overlapping patterns?

Its not bc of my modelled hair or bc of my textures (already deeleted lose, changed the texture, not bc of overlapping hair)

I use eevee with show backface (weird pattern).
I attached a blender file with my hair texture (but the problem happens also without any tetxtures)

hair texture:

link blender file:

(i already made a topic about that, but couldnt find an answer)

Sorting of blended transparency is generally very buggy no matter the rendering engine. It is better to be avoided in some way (use Alpha Clip instead; you can also try making your texture extra big resolution and setting the layer blending to Dissolve in your image editor to create a dithered alpha). In some programs, separating the mesh into layers, then re-attaching them together in the order the mesh should be viewed in (from inner layers to the outer layers) can recalculate the mesh internal subobject order and make it appear correctly. Though I never managed to do it consistently in Blender. Also, unchecking Show Backface sometimes improves the display of Alpha Blend, but it is not to be relied on in case of multi-layer object like hairstyle

1 Like