How do I align several vertices to make an area flat?

Greetings everyone! :slight_smile:

I am new to Blender and still struggling with some aspects of it. Even if I solved every problem that I have met so far, I am now stuck on one part. Not even Google can find my answer, even if this topic is very common. It might be because I use Maya preset or that I have done it wrong, but I honestly don’t know!

The problem: How do I align several vertices? I am trying to flatten a certain area on my mesh, by aligning vertices. I have seen guide that tells me to “Scale -> Pick Axis -> Value to 0”, which does not work, just because they move to the same position as one. Sure, I can take one vertex at a time, but it will take to long!

I want my vertices to align individually, even if I select several of them. How can I do that?

For that particular group of vertices: see how the axis indicator (bottom left) and the manipulator arrows are aligned? That says that the X axis is the one that the verts need to move on to become flattened without moving to one spot. So you would press S for scale, then X for the axis to scale on, then 0 (zero) to say that there should be 0 distance in that axis between any selected verts. The other two axes will remain unchanged.
You should really learn how to do it this way, because it teaches you how to think in 3 space. But there IS a ‘flatten’ tool in the looptools addon that is useful in many other cases where it’s not quite so simple to flatten. You can enable it in user preferences.

you can also use the manipulator to scale it to 0 or near zero, and if it isn’t on a main axis, you can set it to do so oaccording the the face normals of the selected faces.
(edit) other ways would be to make a knife cut, then delete extra geometry >> select edge loop >> extrude >> merge, or place a plane behind them and use surface snapping ( retopo ) to paste them against the plane.

Guess this script could help if you had not the central vertex initially -

Maybe you set Pivot Point to Active Element. Select all verticles you need to align, then with SHIFT deselect and select the one vertex for set him active. And then press S next set axis (X,Y,Z) and 0 - nice tutorial “S scale shortcut”. You can also use transform entry, copy e.g. X axis value from source vertex and paste individually to other.

It seems like I picked wrong axis when I tried this, but now it works perfect! I selected all the vertices, pressed “S” for scaling, picked the axis in the center (X in this case) and dragged it manually. But instead of releasing, I pressed “0”, while I still held onto the axis with the mouse. After that, they all aligned perfectly and I got the result I wanted!

Thanks for all responses, really kind of you all! :slight_smile: