How do I change the shadow color?

well the title pretty much says it all. how do I change the shadow color in blender render? I’m trying to go for an outside photo-realistic effect and one major thing I have wrong is the shadow casted by the mesh is black/gray. I want to change it to a more blueish shade, but I have no idea how. Could some one explain to me in detail how to change the shadow color? I’m still a little new to blender. Thanks

Look in the lamp settings under shadow options. There is a box to select the shadow colour

I have already tried using that and it didn’t work because the plane that the shadow is cast on has the shadows Only option enabled in the shadow tab. I use this option because some of the scenes I use involve real life footage and this option is a good way to get the shadow on the plane without the rest of the plane showing in the render. The down side is that the shadow tab in the lamp options does not seem to affect the shadow. Except for the samples options.
Do you have any more solutions I could use?


If you’re using a shadow only material you’re not really using shadows but an alpha value.
Add the shadow plane to its own render layer and change the colour of it in the compositor

Some how I’m still getting this wrong. I cant seem to have both render layers show their separate objects in separate render layer nodes at the same time. Here is my .blend file. By the way. In your screenshot of your compositor the left side of the cube still has a black shadow but the shadow cast on the floor is orange. Is there a way to make both shadows orange?


example.blend (532 KB)