How do I fix this super horrible render?

I’m very new to blender and 3D in general (literally 6 days ago) and I think I bit off more than I could chew by trying to mash too many ideas in my first project instead of focusing on a single aspect. Plus I really liked how the animation played out and didnt want to scrap it if I could find a viable solution.

I’m a a new user on here and it wont allow me to drop a photo of how its supposed to look so the link to blend file is here:

I get this when I try to render the animation

(my brain almost exploded when i saw this)

Thank you in advanced! :slight_smile:

Well, the first thing that’s wrong is your plane has too strong of displacement on it. You can’t see it because your Subdivision level is too low in the Viewport:


If you make it match the Render level of 3, you’ll see why it looks like that. Turn down the Strength value of the Displacement.


Not sure what else you are hoping to see/not see.

1 Like

That helped a lot! I set both of them to one and got the render to look way better:

This is the look I’m sort of trying to achieve:

but now it wont show the purple object in the render animation even though it’s playing in the layout panel when I play it.

updated project file:

I appreciate the help! :slight_smile:

The “purple object” looks like you are missing a texture.

Ok, it took me a little while to figure out, but the problem seems to be that you have this “Show Emitter” checkbox unchecked in the particle settings on the blob:


In some cases you only want to see the particles, not the shape emitting them. But in this case, you do, so you need to check that box.

Hope that helps!