How do I make things with armatures move?

I’ve made a rabbit and rigged it, but I want to know how to make it move on hills etc. Because when the armature moves, the rabbit goes with it through anything, and when the armature is dynamic, it just shoots away. :frowning: Can anyone help?

Have you tried parenting?

Parent what to what? The rabbit is parented to the armature, that’s why the rabbit moves with it.

I believe you have to make the rabbit itself Ghost property.

I’ve done that but it doesn’t work.

By the way: It’s an RPG game.
Should I put this on the ‘Simple Questions answered’ sticky??

One Solution:

  • Make an invisible cube, sphere whatever to be the characters control object.
  • Add controls for moving to that object.
  • Make the control object dynamic.
  • Parent the armature to the control object.
  • Parent the skin object to the armature (make it ghost).
  • Add logic to synchronize the movement and animations.

No. Doesn’t work.

I think I might need python. Can someone give me the necessary code?

I think you might need patience. The suggestion by monster is correct (if the hills are not too steep), I believe you did something wrong. Also, make sure you are not using dloc for movements - then your character will still go through walls

I have this problem too. :o I don’t have the slightest clue what i am doing wrong…
i have v 2.48. I don’t think could this be a possible bug of that version, because i tried it on an older version I have and it didn’t work on there either. Is there some minor button Rednerrednelb and I could have forgotten to push that NONE of the online tutorials seem to mention? :spin: I will post the file I am having trouble with. I someone of more skill than i could take a looksie at it for me i would be vary thankful. :yes:

My bet is that it is some minor button. that was the case when i was learning to rig. :cool:

ok here is the file. for some reason it didn’t upload in the last post.


runnrattest.blend (350 KB)

delete the “Armature” modifier!
Unparent the mesh from the armature and the armature from the cube ( clear and keep transformation)
Select the mesh then the Armature and parent then ( don’t create bones).
Parent the armature to the cube.
In the Rat logic enable the TRUE trigger button
It should work now…I hope?!

Thank you very much for taking a look at the file. I am trying to do what you said but i am a bit confused on some parts of the directions. when you said:

Unparent the mesh from the armature and the armature from the cube ( clear and keep transformation)

what do you mean by “clear and keep transformation”.

Also, if i remove the Armature modifier from the mesh how will the mesh know to follow the bone movements of the Armature?

I’m sure to most your directions are clear and obvious but you’ll have to forgive me. I am self taught at blender and don’t really know the names for all the things i do there. :o

would you be able to post the modified/corrected version of the file.:cool:

Hello again
“clear and keep transformation” is in the pop-up “OK” window when you do Alt-P to remove “parent”.
As you’ve noticed “armature modifier” don’t work in the game engine
Your mesh already have “Vertex Groups” assigned, so it’ll follow the Armature, don’t be afraid!

to test my model and new animation I actually do both - parenting and armature modifier, so both in BGE and Blender my model responds to movement of the armature, it is pretty handy in 2.49

Thank you so much OTO! It works now. :smiley: