How do I set "Automatic Weight" to a single bone?

Does anyone know how to set automatic weights to a single bone that’s in an armature?
Every time I try, the other bones influence the same object too


I want both of these bones to be automatically weighted to the abdomen object.(I could manually paint them, but then I wouldnt learn it for future reference)

Gazebra4.blend (751.9 KB)
(Blender Model)

  • select the skeleton
  • go to pose mode
  • select the bone(s)
  • shift select the mesh
  • go to weight paint mode
  • space > weight from bones


I did as you said. But in the Space search bar, I cant find “Weight from bones” function. I must be missing something

(I did select both the bones in pose mode. It looks like object mode in the photo though when I click the mesh after selecting the bones while in pose mode).

A mesh you want to weight to an armature needs two things:

  • to be parented to the armature object
  • to have an armature modifier whose ‘Object’ option points to the armature object

This is typically done by

  • selecting the mesh, then
  • shift selecting the armature and
  • Ctrl + P -> Armature Deform

That’s why you can’t see the ‘Weight from Bones’ option because you did not setup the character for armature deformation at all.

BUT

What I don’t understand is since all the body parts are separate objects bone-parented to a single bone, what’s stopping you from simply parenting the torso to the armature with automatic weights?

I’ve got a problem with this in 2.83. I can no longer shift-select the mesh with the armature in pose mode. I’ve tried ‘lock object modes’ on and off without success. The only thing that worked was shift-selecting the mesh in the outliner. Any suggestions or is this a bug maybe?

It’s probably that “fade geometry” stuff that still doesn’t work well.

  1. You need to be in unlocked object modes.

  2. In pose mode, look on Viewport Overlays dropdown, upper right corner of your 3D viewport. Make sure “fade geometry” is unchecked.

  3. There are still some bugs related to bone display, selection from interaction of fade geometry + in front settings for an armature. If you’re having trouble, play with combinations.

Your instructions are a bit confusing. You said to select the bone(s) in pose mode and then shift + select the mesh, but yet you can’t select the mesh in pose mode in Blender 2.8. It is very confusing in what you meant.