How Do I "Vertex Parent"


(Paint Guy) #1


Hi, I want to “vertex parent” a cube to a plane. I created a plane and then subdivided it for each individual car. I then selected the vertices of the plane, then (CTRL + Selected the car) and selected “Vertex parent” but I got an error saying: (Error - Select either 1 or 3 vertices to parent). How do i vertex parent the cube to the plane if it gives me the error. I don’t see how I can select 1 or 3 vertices?


(Nezgar) #2

Select the car (as the child) > shift + select the plane > press Tab key to enter edit mode > select the vertex on the plane (as the parent) > Press Ctrl + P
:wink:


(OTO) #3

Hello
select your vertex, then press Ctrl key and RMB click over the desired object to select it too, then do the usual Ctrl-P!
Bye


(Nezgar) #4

Ah, i didn’t know there is a quicker way to do that. Thanks OTO.

@ Paint Guy, after you did what OTO said, you can move the vertex around, to see the result.

EDIT: Ups, it’s not a quicker way, actually. Just a slightly diferrent way :slight_smile:


(Paint Guy) #5

Thanks Nezgar and OTO. Sorry, I didn’t make my question very clear. I wanted to “vertex parent” 2 or 4 vertices but as far as i can tell it only works if you select 1 or 3 vertices which is unfortunate because I wanted to select 2 or 4 vertices and “vertex parent” them to the cube but I don’t think that works does it?

Another somewhat related question. In a tutorial it says after you “vertex parent” the cubes to the plane, select the plane object and add a “Curve Modifier” to the plane so it aligns with the curve (like a train or roller coaster cars). When I did this the cubes didn’t align properly (see image) any ideas why?

Before adding the “Curve modifier”

After adding the “Curve modifier”


(Nezgar) #6

In that case, maybe best for you to use the “Hook”:

Select your 2 or 4 vertices > Ctrl + select the cube > press Ctrl + H > and then select “Hook to selected object” in the pop up menu.

I honestly never play around with this “Curve Modifier” in blender before, but i think people here can help you better if you attach a simple .blend file of yours, so they can find the problem with your settings.


(Paint Guy) #7

Originally Posted by Atom
You may want to consider it like this…

Create a plane and subdivide it to create a face for every car in your coaster.
The plane should end up rectangular in shape with the required spacing to keep your cars convincing.
Then vertex parent each car to each face of the plane.

Now you can simply apply a curve modifier to the plane and animate that single plane moving along the curve. The cars will twist and turn as the plane does. This works in 2.49 and 2.5.

Nezgar,

Hi, I am trying to get a train or roller coaster to follow a curve. I am refering to this thread here.

Question #1
I tried it myself but when I select the “plane” and add a “Curve Modifier” to it the cubes (cars) don’t align properly. Here is a link to the file I made in Blender 2.7 showing the problem. You can download it here.
http://www.pasteall.org/blend/10615

I disabled the curve modifier, but when you open the file enable the “Curve” modifier and you will see the cubes are not behaving or lining up evenly. I was hoping you might know why this is happening.

Question #2
Also I “vertex parented” each cube to 3 vertices. I tried to vertex parent the cube to 4 or 2 vertices but it won’t let me. It gives me an error saying: (Error: Select either 1 or 3 vertices to parent). If there is a better way for me to vertex parent the plane to the cubes please let me know. Thanks.


(Nezgar) #8

Wow, Atom’s file is pretty neat!
I’ve been doing some experiments with the “Curve modifier” in your .blend, and i have no idea how Atom can achieve that roller coaster animation in his .blend.
You’re right, parenting an object into a vertex can messing up the boxes. But it seems like Atom can deal with that successfuly. I wonder how he can do that.
So far i can only get a train-like animation instead of roller coaster.
See your modified .blend below, and play the animation.

Basicaly, i parent an empty into a vertex on the plane.
For the boxes, i used “Copy location” and “Track-to” constraints.
And another thing that i think you should note is that Atom disable the “radius” and enable the “Bounds Clamp” under the “Object Data” tab. (Properties > Object Data tab > expand Path Animation, and you should see them)
I’m sorry i can’t help you with the roller coaster effect, but i hope my answers above can give you some clues.

Edit: i actually only parent the empty into one single vertex of the plane, not 2, 3, or 4.

Attachments

train_test_010213b.blend (503 KB)


(N.D.Catchlight) #9

Maybe if the cubes are all one object? select them and press ctrl j?


(yogyog) #10

You can only vertex parent to 1 or 3 vertexes. A point or a triangle.

There are reasons for this: A triangle con only be flat. Any 3 points in space will create a flat triangle. Because of this, you can parent an object to 23 points and it can use their position to rotate an object.

All you have to do is turn your quads into tris by selecting an edge and going “merge vertexes”.


(N.D.Catchlight) #11

!! Mira Tools !! this looks like it would work.


(sundialsvc4) #12

If your goal is to make a train follow a track, I would simply treat each car as a separate object and have each one use a “Follow Path” constraint. If they’re all moving at the same velocity they will stay together even if they are not “attached.”

You don’t need any sort of parenting to accomplish this – and there’s a reasonable chance that it wouldn’t accomplish this. I’d think that you’d get “excess motion” that might be noticeable.

A slight amount of hand animation, e.g. slight back-and-forth rotation along a car’s local-Z axis, might further convey a sense of speed and momentum. Along with things like noise-based “camera shake.”