How do you deselect edge loop? Is this a bug?

I want to deselect loop from my selection as shown on the video below. I cant figure out how to repro this with Blender. I wonder if this is a bug since according to the hotkey editor shift ctrl dbouble left click should do it.

I have enabled 3 button mouse so I can rotate my viewport with alt + left click.

(I tried every possible combination with shift + ctrl + alt + click etc… )

Here, you are only seeing shortcuts for edge ring selection.
If you type loop instead of edge, you will find shortcuts that are supposed to work for edge loops and face loops.

But still. There is a conflict with alt left click and double click solution.
Emulate 3 button mouse is old and it will work with a selection by right click.
But it does not with new left click default.
I suggest you to remap shift alt left click to toggle selection of edge loop to shift Cmd left click.

The standard for deselecting a selecting is “select again” and a click on the axis (since 2.8) gizmo also rotates you view.

I deselect edge loop using shift+alt+rightclick. This has always worked for me (for some reasons only with alt and shift on the left side of my keyboard), it seems to be working with 3-button mouse mode as well.

so you create a custom keybinding for deselect edge loop?

Like this (it’s just an example, find a sensible key combination that works for you):