How to avoid meshes from overlapping?

Hi guys,

Just started working on this project:

For some reason, the road and the path underneath it appear to overlap, but in reality, the road is placed a little higher. It might be a viewport bug or something…

How do I go about it?


If they are not truly co-planar, but maybe just separated by a small amount, like a couple of mm, then at a distance, the viewport does exhibit that “Z-fighting”, but if it looks ok close up, it should be fine. I’m guessing a render is ok, just the viewport?

I haven’t tried to render it yet. My guess is that it’s the viewport.
I hope it won’t appear similar within the game engine though.

Then this sould be investigated in the game engine because it is not blender… (or do you use upbge?)

In addition to z-fighting mentioned top, also check your clipping range for viewport (and camera’s clip range for renders). Type sensible start-end values according to your scene.

I actually adjusted that, didn’t help…

What did you enter for the clipping values and how big are the objects in your scene?
Take a look at below video to understand the clipping ranges better. I duplicated a cube and scaled one slightly, so their surface are quite close. It looks okay in close range after I entered 5m for clip start but then it looks bad as I go further away, so I adjust it even more.

The map grid, as shown in the picture, is measured 1 kilometer x 1 kilometer inside of blender, so I actually adjusted the values of the “Clip Start” to be 0.001 m and “End” to be 2,500 m.
Probably 0.001 is set too low for that particular task.

Yes, I believe so. You can actually visualise this by enabling camera’s “limits” option and adjust the clip start/end values of the camera. The line you see in front of the camera is the range you’re displaying and it shouldn’t be too long for Blender efficiency reasons I suppose.
We tend to see such issues when working with too big or small objects/scenes.

Could you share the .blend file? That way you avoid users having to guess about the cause of the problem and they can better analyze the scene.

Increasing the “Clip Start” value actually fixed that problem for me.


1 Like