How to change the image viewer color for transparent pixels?

Hi everyone,
when I render an image containing transparent pixels those appear middle gray in the image viewer. Is there a way to change the background color maybe to have a checkerboard effect like in photoshop, or blender’s own material preview panel?
When I render something that has a lot of gray shading is really hard for me to tell what is transparent and what is just gray by looking at the whole composite. I know that I can see the alpha alone but sometimes I really need to see the transparency in context with the colors.
I have set in the output context in the shading panel to have the alpha set to transparency, not sky.


What I see is here is the default background used for transparent pixels. Here only Suzanne has an alpha of 1.
I have made the material a shadeless gray just to show why I have an issue with this setup.

Here I simulated what I would love to see. A photoshop style checkerboard representing transparent pixels. I used a texture for the world color “horizon” set as paper sky.

I tried to find the color slot in the theme preferences but I wasn’t able to find one.

So, can anybody tell me what to do?

upload a blend file. there could be many reasons to why ur not getting a transparent render. file format? alpha enabled in the node edditer? transparent enabled in the rendering settings? etc.

Hi finalbarrage,
the renders themselves are fine, they have the right transparency. My problem is the way blender previews the files in the image in the UV/image editor.
The alpha is there, is the preview that I want to change. When I test render I want to see clearly where the alpha is, not a composite over middlish gray.
The first picture show the alpha. The second the RGBA full view. See that gray? I want to replace that default color with checkers or at the very least with a solid black, not gray.
Not only that but when I paint in 2D and don’t use a lot of colors not having a way to clearly see the alpha in the uv/image editor is a drag for me.
The third pic is just that render with its intact alpha.
Sending a .blend won’t help. It must be a system preference or a value in the themes setting, but still I cant find it.
By the way the matetial editor shows the checker by default.


These two final images should show why painting without checkers is a tad maddening.

Two gray squiggly lines right?


So, yeah. It may seem a minor complain but for me this is huge. I’ve always seen alpha as checkers and I find very hard to adjust without it.

The standard image transparency view in image editor. The checker colour cannot be changed in the theme settings

Thank you Richard to show that blender actually does that. Which makes me wonder why mine doesn’t. I reset to factory setting and nothing changed.
I always use blender in lubuntu but MAYBE on windows, which I know for a fact has better driver support for my card, things would go smoothly. And indeed I see checkers now! YAY!
So my educated guess is that checkers rely on some OpenGL driver feature that is not working properly for my hardware/driver setup in lubuntu but work just fine in windows. A clue is that the material/texture previews don’t rely on OpenGL and as a result I see the pattern clearly even on lubuntu.
I’m using a old ati card so that may be the issue. I’m asking a friend to lend me a newer card for the afternoon and see if this solves the problem. If it does this is more likely to be a ubuntu/driver issue than a blender one, at which pont I would care anymore because I’m about to upgrade my hardware. Otherwise I’ll report it as a bug.

In the end, I’m really happy to know what’s going on, but is there a way to dial in the colors of the checkers? Changing themes won’t help, I guess it cannot be done.
Thanks for the replies!

I checked with the newer video card and proprietary nvidia drivers and it work perfectly.
It’s just a driver issue.
Blender is behaving good.