How to completely disable shadows in cycles?

Hello! I’m here to ask about a problem I’ve been having for quite a long time now. Even when dedicating a good couple of hours desperately trying to fix it yesterday, I just can’t get it… the problem is simple: I can’t disable an object’s shadow completely. Whether it’s through nodes, turning off the shadow ray visibility, or even making it semi transparent, including combinations of all these things, no matter what it seems a shadow is still casted. I’m not sure if this is intentional or maybe I’m just missing a super simple setting, but no amount of looking it up has helped me, so I’m resorting to this as a last resort at the expense of looking a bit silly if it really is simple. Heres a picture of what I mean, shadow ray is unchecked (and just to be as clear as possible, these are separate objects too. This problem is nonexistent in eevee)


If you mean the black spots in between those models, it’s probably shading not actual shadow. Most likely the model underneath doesn’t receive light and is rendered darker. You may have to use composition to render those objects separately then mix the final image. Or use some emissive materials or something that doesn’t depend on lights.

First off, welcome to the community @ShiftSIke! Like @Blutag said, this could be shading - not shadow. Years ago when I started, I struggled with which effects were caused by a lamp’s contribution to a scene and which effects were achieved at the surface level. Would you be able to post a screenshot of your material settings? There may be a way to achieve the look you want by performing some other function. Additionally, can you explain why you want to render your scene without shadows? That will also help us find the most expedient path to a solution. Thanks!

Usually better to attach a .blend file. My eyes are getting too old to peer at attached images of node-networks and the like.