How to create an evenly offset inward extrude/inset? Tried many options

Hello. I am new to the forum and new to Blender. I have tried numerous methods to create the binding on the edge corners of an acoustic guitar I am modelling. I have tried extruding, insetting, using ‘option’ + ‘s’. In all cases, the thickness of the resultant inward extruded shape is not of even thickness. If you look at an acoustic guitar you can see the edge between the top, back and sides, usually has a thin, evenly thick strip separating them. This is what I am trying to create.
Any ideas on how to do this, what I am or doing incorrectly?

Below is a screen capture of using ‘option’ + ‘s’. It is easiest to see the left and right ends are slightly thicker. but it does vary in thickness all over.

Try with only the outside edges “f” to fill, you will get an ngon, then “i” to inset. It usually gives an even offset. If not there is an addon somewhere to offset edges.

Thanks D Norman for taking the time to help and the suggestion. Unfortunately using an edge to inset did not work. The resulting inset was the same as my screen capture, though with your suggestion, the whole area was additionally filled.

I should note the initial starting shape in the screen capture is a flat band of faces, the screen capture is looking at it orthographically with the resulting inset, at 90 degrees to the starting flat band of faces.

It seems strange this is not an ‘easy’ function. I will look about for an inset-type addon. Thanks again.

Look at the bottom left corner of your screenshot.

It should work, what I meant was to select only the edge of the rim (it does not matter if there is more geometry on the sides) an press fill - yes it will create a guitar shaped ngon filling the form, then do the inset (i), then you can delete the ngon face that fills the shape.
Stan_Pancakes is also right there is the even offset option.
None of these methods will work if your object has non uniform scale.
I think your problem is that your object has been scaled in object mode. Go to object mode and apply the scale object -apply- scale and the try again.

Hello Stan. Thanks for the pointer and taking the time to reply. I noticed and tried that previous to your suggestion and it did not work.

Hello Norm. I understood your suggestion from your first reply; your explanation was clear enough to me.
Your idea of non-uniform scale worked! Thank you! YAY! I naively did not realize copied objects retain the attributes of the ‘mother’ object. I assumed the copied object would be a ‘blank’ object as far as it’s transform attributes.

Yes, the scale rotation thing hits us all once in a while!
I can see the logic of it affecting modifiers but not so much edit commands, but it does!
Happy Blending!

Thanks again Norman! I will have to keep the ‘transform attributes’ more in mind when modelling in Blender - not a big deal to do. That I find it quirky copied objects inherit the ‘mother object’s’ transform attributes will help me to remember.
I really appreciate your help!