How to create idle ocean waves with Flip Fluids

Hello all, I’m trying to create an ocean scene with a submarine breaching the water as it surfaces. I want to use Flip Fluids, but I don’t know how to get idle ocean waves to appear on top of the flip fluids. I’ve seen some video examples, but no really good tutorials on how to do this. So far I was able to create a plane, and used Displace modifier to create waves. My understanding is that there is a way to get those waves to appear on the top of the flip fluids. So far I have not been successful at this. Can anybody help me with this? I am using Blender 2.81 Win 10 64bit.

The displacement modifier on your Plane object is displacing the plane geometry. The FLIP Fluids surface mesh is contained in the fluid_surface object. So to get those waves to appear on the simulation, you would need to add the displacement modifier to the fluid_surface object to displace the fluid geometry.

One way to duplicate the modifier from your plane to the fluid_surface is to use the CTRL+L ‘Make Links’ menu. Documentation: https://docs.blender.org/manual/en/latest/scene_layout/object/editing/duplication.html#make-link

I have a post here that might be helpful: FLIP Fluids Addon: A liquid fluid simulation tool for Blender

This post describes a similar technique to add displacement to the fluid_surface and contains a sample .blend file. The only difference is that it uses an Ocean Modifier instead of a Displacement Modifer, but the technique is similar.

Hope this helps!

Thank you!!! This is very helpful. Some questions I have…
I select the “Fluid Surface” . I add the “Ocean” modifier. But when I do this. I get a very flat ocean plane. What do you do to get the ocean modifier

to stay the same as the fluid or domain?

By default, the ocean modifier generates an ocean plane. By setting the Geometry option to Displace, this will displace the fluid mesh instead of generating new plane geometry.

There is a screenshot of the modifier settings in the linked post:

image

The rest of the ocean modifier settings can be adjusted to get the right look for the waves. This documentation may be helpful: https://docs.blender.org/manual/en/latest/modeling/modifiers/simulate/ocean.html

1 Like

OK… Very cool. Set Geometry to “Displace” OK. Got it! Thank you!!!

So Awesome! Thank you so very much for your help on this.

Thank you again, for your help with getting ocean waves to show up on my fluid surface mesh. Now I’m trying to create a more expanded ocean using the Ocean modifier on the Plane. The thing is I really like how the waves look on the plane and want that to also be on my Fluid mesh. I tried following the tutorial you recommended on youtube, but I am getting confused and I’m not getting the results I was hoping. I selected the plane > hold shift > select the Fluid_Surface > Hold Control L > link the modifiers. When I do this the flip surface turns into a tiny plane. I have to change it to Displace to get my filled fluid back. When I bake the animation. The flip fluids does not match the ocean modified plane. What am I doing wrong?

I think I might need to see a .blend file to understand the issue better. I think the displacement on the fluid mesh should match the larger ocean plane when the modifiers have the same settings.

Note: the modifier will only displace the vertices of the mesh. So if the fluid mesh is less dense with vertices, it will not show up as detailed as the larger plane. For a more detailed fluid mesh, either increase resolution, or increase subdivision level of the generated mesh to 1 in FLIP Fluid Surface panel. Both will increase vertex/polygon density.

@RLGUY Thank you for the advise. I would love to share my blender file with you. Message me a link or something that I could send my file to.