How to disable alpha channel on a texture in Solid shading mode?

in 2.8, i have a principled BSDF shader using a base colour texture that contains an alpha channel. In the viewport I am working in Solid shading mode, and using the Texture for colour. The alpha channel is NOT plugged into the alpha of the material.
The problem is that the alpha channel of the texture is behaving like an alpha clip and making the texture either 100% opaque or 100% transparent. The material is set to Blend Mode Opaque, tho I don’t think that setting is even for the solid shading viewport. How can I disable the alpha channel in solid shading mode?

cheers

did you ever get this to work? I am experiencing the same thing with a BSDF with emission / alpha / color for 3 maps, if i detach the alpha it works in solid, if i attach alpha, i only can work in material preview mode,

to compensate i just use the albedo + emissions in solid, and then for alpha stuff i wait till the end and deal with it, which kinda stinks but for low poly stuff its ok… don’t really use too much transparency so i just make it solid blue and later on i’ll swap the maps and deal with it.

did you ever figure out the right way to get solid to show the alpha or ignore it?