How to edit the background color ?

i checked the user interface color settings but wasn’t able to find where to change the viewports background color. Its just too dark to see the wireframes well on it.


Scroll down and change the ‘Gradient High/Off’ colour

You can also change the background in the Properties editor > World context panel.

k cool thx :slight_smile:

No probs…

changed bgd values in world settings, but its not yet catching …

This is for when you render the scene, not for the interface itself. For the interface you need to change the colour in the User Preferences / Themes settings

k tx ,

Here is where to change it:

Themes - 3 d view - Scroll down to Theme background color - it’s color on right side there change it.

Also remember You can change Wire color for Edit mode…Also in 3 D view - top right…:slight_smile:


k cool ,

You can check World Background in the Display Options (N hotkey panel) of the 3d View and it will change the viewport background color to what you have as the world color.

What I told him is accurate. I never went into User Prefs to change mine. I did it in the World context panel. What you guys are telling him is either another way to do it, or it’s wrong.

EDIT: I forgot to mention that you also have to go into the properties panel of the 3D viewer under Display and toggle the World Background checkbox.

You can do it the way You say…But…If you use Environment Texture is perhaps not the best way to do it…It can work if it’s Studio light -Hdri You use else…Hmmmm…:slight_smile:

Do it the way Richard told You…That’s the right way…It’s the Theme background You change Not the Worl background.


World Background - In N Panel - is made so we can see Environment Texture in viewport Perspective Mode…:slight_smile:

Puff Puff


I use the gradient in the properties for “3d view”

works great

Incomprehensible posts… :eek:

There are two background colours

The colour of the 3d viewport. Changed in the User Preferences / Themes panel. This is what the OP was trying to do in the first post but did not know which of the theme settings changed this colour. The background can be a solid colour or a vertical gradient from colour A to colour B

The ‘World Background’ option in the properties panel displays the world colour of your scene in the viewport, whether that is the world colour or more usually a world texture. Note that if you change to one of the fixed perspective views (Top, Front etc) the colour will be that set in the themes above.

I’m sorry, but that isn’t what I have. My Themes background color for the 3D viewer is still set to the defaults, but my World Background color is set to gradients of blue that I set in that panel.

In Ortho view (top, bottom, front, back, right. and left) the color is blue as well.

As others have pointed out Themes Background color and World Background color are two different things .
World Background color is what gets rendered.
Enabling World Background in the N panel you just simply overlay that color in the 3D View.

Disable the N panel option ( read your own post #12) and hit render again you’ll see it renders blue but the 3D view is grey color.
Hope it makes sense to you now .

Okay. Now I understand. Thanks for clarifying.