How to fix NVidia TDR error on Quadro cards?

I was able to render it (Workbench/Eevee) using FHD resolution.
But I’ll leave the original question below in case it’s needed in the future.

I’m working on an inhouse production scene of less importance, trying things and different concepts out. At work on Win10/NVidia Quadro M4000 GPU I’m immediately hit with the TDR error - two seconds in it gives me this:

I can’t even render it using Workbench, and although some shaders are heavy, the scene itself is really not that bad (yet). Seems to work with Cycles, but crashes after a couple of seconds using both Eevee and Workbench.

I tried adding some registry entries to change the delay, but it didn’t work. Not sure if this applies to Windows10 or Quadro cards, the article doesn’t specify.

I also tried installing NVidia NSight as advised here, but I’m not getting the same interface or options as in the article.

So basically, what do I need to do to increase the timeout delay for NVidia Quadro cards on Windows10?

Another option is…

but if you are on a portable there are 2 set of timers to be change
I think a similar problems a few months ago !

happy bl

Sounds like a similar issue that Substance Painter has. I have to correct it every time I update the video card drivers.

Watchdog describes for windows XP (and later), but the watchdog registry entry is lacking from my system. I do recall the behavior “revert to VGA”, which is not what is happening here though.

The Substance Painter issue sounds much more similar, but I have already tried adding those entries (they were missing) without it actually preventing the crash. Are you using a Quadro card? I have to use the certified drivers for Solidworks.