How to fix shading issue

hey so im trying to make these fence with 4 cylenders (each has 12 verts) i joined them all using a boolean and fixed some of the miss verts but when i shade smooth and do a auto smooth i keep getting shading issues how do i get a smooth shading for this fence:

![3|690x219]

The model i want to make

Check Object Data Properties > Normals > Auto Smooth. Tweak the angle if needed.

Yes i tried it mate despite that im having bad shading i honestly don’t know why!

Can you upload the blend file to take a closer look?

This is a topology issue, you have created some Ngones (faces with more than 4 sides), There is an addon bundled with blender called «extra objects» enable it and then go to - add-mesh-pipe joints and add a T joint. It will add a T joint with correct topology and you can see how you should join them properly.