HOW TO GET RID OF BASE COLOR ???

Well i did a search, and after looking thru 8 pages i posted , sorry if its answered somewhere. Any way, i have a halo set up, im using the colors in the texture ramps to color it, but no matter what i do i cant get the default base color to go away (ma:material default grey). how do i get the default color to play no part in the halo colors ?? ive tried a lot of different things but no matter what the color you can always still see it in the halo, i need it to be completly gone. Is this possible ??

Yes. Here’s how:

  1. In the “Material” panel you need to set the halo color to 0,0,0 .

  2. In the “Map To” panel change the texture blending mode to “ADD” and make sure you have the “Col” button pressed.

You’ll also want to have the “Col” slider set to 1.000 so the color of the texture has full effect.

  1. In the “Shaders” panel you can make the texture map to each halo instead of the whole object by pressing the “HaloTex” button.

Halos are kinda tricky and don’t always work like you’d expect so keep that in mind. And its best when using halos to have the Unified Renderer turned on in the render buttons (F10) under the “Format” panel.

One last note the lines and rings of a halo don’t seem to be affected by the texture and their color is set separately in the “Material” panel.

Hope that helps.

Thanx you Sonic, that fixes it. Have a Happy Newyear.

:slight_smile: You too.

When I make a .jpg file of a view for ultimate printing I always get a gray background. Can I change that to “nothing” so that only the black outlines show on the print?

Thanks, Lou

Ok I’m not completely sure what you mean but here are some ideas:

If you mean the world background color then you can change that by going to the “Shading” buttons window (F5), once there click on the “World Buttons” sub-button (looks like a planet). You’ll see alot of options there which I’m sorry I don’t have time to go into right now, haven’t even messed with all of them myself but you can do some neat stuff with them.

Ok if that wasn’t it then here is my second guess:

You are printing your images? I’d suggest you save them as a PNG or some other “lossless” format. To do that you need to goto the “Scene” (aka render) buttons (F10), then in the “Format” panel you should see a dropdown list with JPEG selected, change that to PNG. You might also want to bump the quality setting upto 100, you can do this at any time before or after rendering as the image is stored in the buffer until you press F3 to save it.

Hope that helps. If not let me know and we’ll try to get it worked out.

OK,
Tried the F8 button and changed the background to white. When I press F10 and then the render button it works correctly - the background is white. I was trying to do the same thing with the “quick” render. This button is located on the main 3d view window to the right of the layers buttons. When I press this render button the background is still gray. I would like to save this as a .jpg or .png file and print it with a white background.

Is that possible?

Thanks, Lou

No, that’s an OGL rendition of the Viewport without OSA, World, Shadows etc…
You could save it with Ctrl-F3 and fix the background color in a paint prog.

%<

…or place your cursor between the top of the 3D View and the main menu bar at the top of the screen (so that it turns to an up/down arrow), click and drag it down to reveal the preferences, click on “Themes”, and change the sliders to the background color you want. If you don’t like working with the new background color in the 3D Views you can just as easily change it back after you do a quick render.

Hope this helps.

…or place your cursor between the top of the 3D View and the main menu bar at the top of the screen (so that it turns to an up/down arrow), click and drag it down to reveal the preferences, click on “Themes”, and change the sliders to the background color you want. If you don’t like working with the new background color in the 3D Views you can just as easily change it back after you do a quick render.

This works just fine, thank you.

Lou

The color im talking about is the default color, when you first make a material of any kind, blender creates a default material with a grey color rgb 800,800,800. Well when ever i try to make any material with transparency of any kind, that base color {no matter what it is } is always present somehow, say for example i want to use the colors from the texture channels {ramps} instead of the color in the material tab, i can see the colors from the texture ramp …but there is always some of the color from the material tab still in it…thats what i want to get rid of, i want the color in the material tab to not effect the colors of the material/texture in any way, like it doesnt exist .Even when i use an image as the color for the material there is always some of that color from the material tab in it. I only want to use the colors of an image or texture ramps to color the material with none of the color from the material tab (which starts out at default as grey as stated above). Im not talking about the color for backrounds im talking about colors for objects only.

Ramps are NOT textures, they are Material indices of the Color and/or the Specularity of the Material.

If you want a Texture, procedural or image, to show on top of an Alpha material you need to map it to Alpha in the MapTo tab in F5 and set ZTransp or RayTrans on in the RayMirror tab.

%<

Umm fligh…texture tab…color ramps ?? whats that ?? Anyway my problem is about getting rid of the base color not working with the alpha, i know how to assign that, the problem is the base color is still there in the material when i only want the values from the color ramps in the texture channel.( for example clouds procedural texture set the color ramp to blue) Go back to material tabs, set alpha on, refl on, col on, etc. The base color of the material can still be seen for example if you left it on the defualt grey colors …you can still see the color in the material, and i dont want to , i only want the colors from the color ramps i set in the texture channel. The color i dont want is in the box that says ma:material on what i believe is called the material tab. Sorry for not having all the proper terms down yet…

Well in blender you have to turn on Z-Trans or Ray-Trans for things to be transparent, it’s a bit convoluted really. If you only set the alpha then it will blend with the background color. Halos don’t work like normal, I’m not sure why maybe they need to be updated. But if you have a normal object then you’d also need to turn the Alpha slider in the Material panel down to zero and have to texture add to alpha and color.

http://download.blender.org/documentation/htmlI/ch10.html

http://download.blender.org/documentation/htmlI/ch11.html

You really need to read the docs about Materials and Textures. What you call “Base Color” is the color of a Material. Anything that has buttons in F5 relates, directly or indirectly, to Material(s). Color Ramps are material characteristics, like steel is silver but has a blue color dispersion, cast iron is silver but has a white dispersion.

When you put a texture on a Material it’s like putting paint on steel or cast iron, or, in your case, putting a label on a bottle. All Texture inputs are in the F6 buttons only. How they relate to one another (one texture affects another) and how they relate to their Materials is accessed thru the Texture, MapTo and MapInput tabs. Tabs, or Panels, are those little floating windows in which buttons are grouped.

%<