How to get rid of remnants of Alpha Mask in Cycles?


I am using an Alpha Map in Cycles. The masks gets me 99% of the way there, but instead of becoming completely transparent, a tiny amount of what’s supposed to be transparent is still visible.

It’s hard to notice, so I’ve drawn in an outline as well. I just want the mask to be 100% transparent, without this black outline!

In my nodes I’m using the alpha from the .png image. I tried creating a separate alpha mask in photoshop, but it had the exact same effect. I’ve tried using a .jpg instead of a .png, to no effect.

Under light paths, I’ve tried increasing the number of transparency bounces from 12 to 128, but there was no difference in the images.

I have no idea how to fix this problem, and would very much appreciate a solution.

Is the color of the Transparent shader pure white?
Does the alpha of the image really have zero opacity in the transparent areas?
Try rendering with more samples.

Try using the RGB Curves node to increase the contrast of the Alpha output of your image.

can you show the mask alone in UV editor

another thing is this in viewport only or also in render ?

best place to look for color is in the UV editor not the viewport !

try to add a gamma nodes and see if it changes anything !

happy cl

If you had used Feathered option for the mask in photo editor you could have had tiny bit non transparent around the cut out.
Does not happen here as it looks.