how to make a shadow only plane in cycles

there was a post about setting up a shadow only plane in cycles but i just cant find it…

please help:)

Click on “Object properties” (little orange cube in the properties panel) then uncheck everything but shadow in “Ray visibility.”

Have you even tried this before posting?
All this does is to disable ecerything from the selected object but to cast shadows. It does not enable the object to receive shadows only.
Or better explained, if you disable “shadows” it does not cast a shadow anymore.

I don’t have the simple answer, but I think the only way currently is to use renderlayers and composite the shadows.

nd on top of that this should be in the Support>Rendering&Lighting section. :wink:

That’s not what you told him. All you said is to disable the “cast shadow” which is fine, as you don’t want your shadowcatcher to cast any shadows.
However, if you do the above, you get a rendered groundplane with the shadow of an object that is not rendered. I am certain that’s not what the OP wants.

To me it’s quite obvious the OP, like everyone else asking about this topic, is looking for a method to set an object to only receive shadows and nothing else, like the “shadow only” option in BI.
You tell him to disable everything besides “cast shadow” which is the exact opposite, now it only casts shadows.
The OP is looking for the object to receive the shadows only.

Which is not really possible at this point AFAIK. You can only use the compositor and patch together the shadow pass, which also delivers the geometry.

If you remember, in BI you set your material to full transparency and shadow only, and all you got (with quite a few false shadows - which has been discussed to death in the last years) was an alpha layer with the shadow.
All cycles gives you is a layer with the renderd shadowcatcher with the shadows on it.

I don’t know of a material node setup, that receives shadows only.
The shadow pass for render layers also delivers the diffuse etc. data.

But I’d be glad to be proven wrong. Just post a .blend with a groundplane that is rendered transparent and only holds the shadow of another object floating above it without mixing the color information of the shadow catcher in the final frame.

@arexma thx for understanding/explaining my needs in this case.

like i thought: fiddle around with renderlayers:(

yes, there’s a dedicated shadow pass since some time ago

I have a small twist on this problem. I want to have alpha shadows, and the plane should be totally invisible, and output this to a PNG so only the monkey head and the shadow is present in the file.

This would allow compositing the image in Photoshop, for example.

Is this doable? I managed to get the shadow pass working fine, but how can the non-shadow data be converted to alpha in Cycles or the compositor?

Attachments


file to autosave layers for post edit without rerender.
Could be improved a lot but works for me:


http://www.pasteall.org/blend/17986

black monkey? scene is lit by texture -> missing world texture:



ColorWheel for backdrop col
you can change the shadows and reflection with the so named nodes.

color bounce update from floor to monkey is missing and might look wrong in extreme changes.
it would be great to be able to link the backdropshader color with the backplate color in the node editor. ideas welcome:)

File to reload layers:



http://www.pasteall.org/blend/17985

dave62, great response. Correct me if I’m wrong, though, but there are no alpha channels in the file.

I specifically am looking for a solution where the shadow catcher is transparent, and that transparency is outputted to a file with an alpha channel.

i thought it would be more comfortable using the node editor…

ok, try this:



http://www.pasteall.org/blend/14239

In the node editor there is another FileOutput “forDanilius;)” saving the backplates shadow and reflection as png with alpha channel:)

Dave62 - I stand humbled before your genius! Thanks a million.

It’s these sort of occasions that serve to remind me that Blender is not simply some software, but truly a collective undertaking, and demonstrates the power of open-source: people like you helping people like me who are nagging!

In case anyone finds this thread like I did (this did make me find the right solution), in modern Cycles turn on ‘Shadow Catcher’ under Object Settings > Visibility.