How to make decent glass in Blender?

lasitesti2.bmp (1.4 MB)

On the left is render made with Now3D and glass cylinder has 32 sections.

On the right is render made with Blender 2.79b and glass cylinder has 256 sections.

Question is, why Blender produces jagged edges on the relflection and how can I get them smoothed out?


Blender 2.82, with a simple 32-sided cylinder and a Glass Shader … (EEVEE)

Ok, perhaps I should give version 2.82 a try. On the other hand, your render has no reflection and technically IOR is too low for glass.

Of course, here I lowered IOR for more visibility.
Normally, I’m more on a value around 1.33 … :slightly_smiling_face:

Could you share a .blend file where you can reproduce the jagged edges problem, with images whose license allows you to share it? Do not forget to pack image in .blend file.

Here you go…

viskilasi.blend (489.6 KB)

The HDR was too big, but you can find it here:

The HDR I used is called pisa.hdr

Select the cylinder, in object mode you press the space bar key and search for “Shade Smooth”, apply it.
Then you could go to Edit mode and add more geometry by adding more horizontal Edge loops. Or you can enable “Autosmooth=30” in Data tab > Normals (2.79)

Ok, now it’s even more strange…

I’m sorry, you see the edition of my previous message

Exactly what I said on my answer. . beautiful image with all the indications… :innocent:

At least now, he is sure that his “deformation” came from this… :+1:

Autosmooth didn’t change anything. I also don’t want add any edge loops as that should not be needed in my opinion.

I got identical result compared to yours with lower IOR, but that removed reflection, which is not ok.

Oh sorry. I missed that.

If you refer to jagged edges, you must have forgotten the other part of the instructions (Shade Smooth)

I applied the shade smooth, but it turned reflection upside down and distorted the edges as shown in my latest picture.

Not sure if you are referring now to jagged edges or another problem:
viskilasi_mod1.blend (500.4 KB)

The problem with jagged edges changed into distorted reflection.

Your file produced much better result, but how?

Reflection or refraction?. What you see in my file looks good or is there something wrong with it?

Your file looks good, but I can’t produce the same results.

Perhaps this is caused by different versions? You are using a later version than 2.79?

Maybe you don’t find where Autosmooth option that users already recommended you is?. See properties panel here:
viskilasi_mod2.blend (500.4 KB)

From your original file, there are two steps already mentioned that you must follow.

I had uploaded an incorrect file, now that is correct.

I give up. I have applied shade smooth and autosmooth (which is just “smooth” in 2.79 and has no parameters) and I have also subdivided the whole thing several times.

Reason for my failure must be that I can’t give any value for autosmooth.