How to make the "object applied to hair" bend like the hair?

So I just have normal hair particles with either Brownian motion applied or combed manually.
Basically the strands are bent and not straight.

When I go to the Render panel and choose render “Object” and select an object, it does not curve like the hair particles.

I don’t have an answer, but have the same question…

When I apply an object to the hair, it doesn’t deform like the hair, it just changes in height. Here’s a sample showing the hair (left) and the same particle system with the “Render” set to “Group” which is some modeled wheat (right). (This is just a test, I intend to have thousands of stalks).

http://db.tt/cBj9Vqp

How do I make the wheat bend and sway like the hair? Ultimately, I would also like to comb and style the “hair” (wheat) and have the object behave the same way.

I’ve tried making softbodies out of the wheat, but get the same result (or worse due to the wheat looking like jello, and not bending). I’ve also tried weight painting the wheat, without success.

Anyone have any tips or pointers?

I have a more basic question related to hair particles visualized with dupli-objects.

In 2.49 when you could see the dupli-objects in particle mode, but in 2.58a, it seems you can only see the strands when painting, and have to toggle back to object mode to see the final result. Was this functionality removed, or am I missing a setting?

Thanks!

p.s. to the above posters, its not ideal, but have you considered hand-animating 5 or 6 variations of the desired dupli-object, grouping them, and then using that group to populate the particle system? It’s obviously not as nice as being able to use the actual hair dynamics, but with some random rotation it should hopefully look passable. Would be even better if blender let you play back dupli-object animations with random time offsets to add even more variation!

Been researching for days and found a solution!

The “Particle Instance” modifier.

  1. Set the particle system to Render / None (not ‘Object’ or ‘Group’)
  2. Select your object and add the “Particle Instance” modifier.
  3. In the modifier settings, select the object with the particle system.
  4. Select ‘Create Along Paths’.


Still need to play with the settings & clean up my model (getting strange behavior), but I’m glad there was a simple solution. You can also comb the particles just like regular hair.

Updated clip & .blend here.

@Shteeve, thanks for the ‘dupli-animation’ tip. I was trying this yesterday. It seems like it would work using a curve deform and using Rotobezier (add-on) to animate. But I think this is much simpler for what I want to do.

3 Likes

@overkill, awesome! that solves my issue as well! i can now happily paint my 3d forest!

while i’m here, i just wanted to clarify if i understand correctly: do objects that will be instanced by a particle system have to be oriented such that their “up” axis points along Y rather than Z? this seems to be the case for me, and it seems so weird, i just wondered if i had a setting wrong somewhere (selecting those axis toggles in the particle instance modifier doesn’t seem to help)

thanks again!

I noticed the Y-axis thing too. I don’t think we’re doing anything wrong, that’s “just the way it is” (I’m curious to know why also).

I noticed you can’t randomize grouped objects with this method. I’m guessing I’ll just have to overlay multiple particle systems with different objects.

And the “Create from: Size” checkbox seems a little strange (v2.48a). When checked you can set the particle system to render an object or group (but leave the object blank), then adjust the size & randomness. But it seems to only affect the X/Y scale(?). All objects are still the same height as the hair length.

Also noticed the “Children” checkbox (in the modifier) only seems to work with “Interpolated” (children).