How to make Undo work normally, how to prevent pose loss when changing modes

Hi all, just made a jump to Blender (used to be a 3DS Max, Poser/Daz3D/Bryce, Lumion user) after a 4-5 year hiatus in modelling. Came in and nabbed the new Blender 2.8 and it has been a problematic change to say the least… I’ve worked through most issues, but this series of problems is ultra frustrating.

So, I make a rig, sculpt a model, parent the rig to the skin, introduce actors and objects to my scene and start posing… Now I have encountered a few big issues…

  1. The Undo/Ctrl+Z function seems to be broken altogether. I was posing my model’s fingers (to create a statue for 3D print) and lazily chose not to switch from solid to wireframe mode thinking I knew where the bones were, but the mouseclick grabbed some upper arm bone instead and what went from rotating a finger a few degrees became the whole hand suddenly jumping up off the screen… No problem right? Ctrl+Z to the rescue! Press Ctrl+Z and BOOM! Back to square one. The whole scene defaults back to the static point that each object and actor was loaded in at – roughly 4 hours of work down the tubes.

I then tried using the Undo in the “Edit>Undo” drop down. Same result. Another 2 hours lost. Read a bunch of things online, most not for version 2.8, no real help. Found a comment answering an unrelated question about 2.8 where someone said that they would only use “Edit>Undo History” and that worked for them. I tried this, and although a bit of an awkward pain, it worked. I also increased my Undo steps count 250 in system settings to allow it to store more frequent changes. It still misses steps but a heckuva-lot better than re-pairing your armature with your skin and re-positioning all objects, then posing your model from square-one every single time you make a mistake.

  1. Switching modes resets everything to default also… Thinking I was through the issue my caution level waned. I spent about 12 hours getting everything just perfect. I decided that I wanted to slightly rotate an object in the hand of my model and swapped from “Pose” mode to “Object” mode and BAM! Again everything back to the default position. At this point I think, well, I’ll just click undo history… The only option is now “original,” which does nothing but make the screen blink once as if reloading the scene to default. I then think, well, maybe if I go back to “Pose” mode then hit Undo History… Nope, everything is now default in all modes and the only undo available is “original.”

  2. Started over again… Now 3 days into this nightmare. I start hitting “Save a Copy” after every few adjustments I make. Again ran into a problem where I need to swap from “Pose” mode this time to “Edit” mode and once again – everything jumped back to default and Undo History had only one option “original.” I thought, Ha ha! I beat you - you devil of a program… I saved 93 versions of the scene!!! I load 93… Default position… I figure it must have autosaved, so I loaded 92… Defaults… 91… Defaults… I then thought – Crap, it’s saving over with the current model… So I completely closed everything and then relaunched Blender and then loaded save #90… Defaults… I then deleted the entire scene, relaunched, ran CCleaner to clear any cache in the RAM, restarted my computer, launched blender, then opened #89… DEFAULT POSITIONS!

I didn’t know if I should just quit trying or kick a giant hole through my 65" 4K Samsung monitor, or maybe thrown my CyberPower Fang III Black Mamba off an overpass onto I75… Gladly, I did neither, and started hitting forums… This is now forum stop number 4…

Does anyone know a way to save your models in a manner that prevents them from returning to the default static T position and hold their pose between sessions and mode swapping? I don’t understand why this isn’t automatic when working within the same scene file, but Blender 2.8 seems like it was intentionally designed to be a total headache so you’ll buy their plethora of training DVDs, Books, Online Tutorials, etc. It’s like the Freemium game of the 3D graphics world…

I’m also downloading 2.79 now since all support seems to revolve around using versions 2.5 through 2.7 (which seem to have the same command key shortcuts and whatnot) which is totally different in 2.8.

Any help is greatly appreciated, thank you in advance!

Figured I would update my own question, answered by Jude Desir on StackExchange…

So, how to get the undo function to operate normally you simply insert a keyframe or turn on auto keyframes (the little record button at the bottom). This also repairs the failed save feature as well.

Just in case anyone else may ever find this useful to know…

I have same problem when using blender 2.8. Recently i found the way to undo in edit mode after downloaded the latest built of Blender 2.8. Go to Preference - System - then Check global undo and save preferences. Now you can undo things in pose mode!

Global Undo should be enabled by default. Apparently there is a problem where some addons can modify that configuration without re-establishing it again later:
https://developer.blender.org/T63839