How to make viewport/camera background truly black in workbench?

Hi – I’m doing workbench renders of 2d motion graphics.

Using 2.81, if I:

  • start with a blank config directory
  • go to the Properties -> World tab, change the Viewport Display to black (0,0,0)
  • in the “Surface” pane turn off “use nodes” (changes world surface color to black)
  • change the render engine to Workbench
  • hit numpad-0 to assume camera view
  • use viewport shading drop-down to change background to “World”

…it’s clear that the “black” inside the camera frame is not pure black, but near-black. This is also the case if I do an F12 render: the background around the cube isn’t black, but a hash of near-black pixels. I assume this has something to do with the render sampling of the scene. Is there a simple way to make it render to true black?

Thanks!

Do you have a volume shader for World? If no, at least the background in render should be the blackest of black, and without any render noise.

Thanks for the reply – there is no volume shading, see the first post: if I do exactly as described above, I see this in the viewport:

example

…you can see that above the dashed line (i.e. inside the camera frame) there is the not-true-black. The same kind of pattern shows up in the F12 render (bottom right of the cube, enlarged):

example2

I see it in the viewport, but not in the render (even when increasing brightness/contrast in the image editor). For the viewport I’d say it is just some active overlay (grid, floor, or something).

Thanks – what version of blender and OS are you using?

Did you have the time to try the steps with a fresh config directory?

(The background appears for me (in both viewport and render) with overlays on or off. I just can’t think of what might be causing this…)

It was some 2.81 devel version on Linux. Could you maybe post your blend file? That would make it easier to compare.

Sure – here’s a demo blend file.

For the record, I’m on a recent 2.81 beta, linux as well: 2.81-52bdf522afcd

black_demo.blend (531.3 KB)

I note also that I can place a black plane in the background and it renders to true black, so it does appear to have something to do with world settings…

Ah, okay. Now I see it. Must have been something wrong with my color management settings.

But I can’t figure the problem out either. Blend file looks okay to me. Strange, but same behavior in 2.80 and 2.81. Probably no one else has noticed, as workbench is less popular and one has to look really close.

Thanks for confirming – I’ll report a bug and see if they agree that it shouldn’t happen.

Edit: bug here: https://developer.blender.org/T70288