How to map long rectangular earth texture on a sphere?

If I create a new file and do that, by default, it seems that Blender correctly maps the image on a sphere, as people would want.

But I have a screwed-up file that I cannot get this mapping back. I could create a new file and start over, but I wonder why it does not work. If I choose “smart UV project”, it becomes like this:

If I choose “sphere projection”, it becomes like this:

If I choose “cylinder projection”:

How do I get the default projection like the first screenshot? In case if you need to examine the file, here is the screwed-up file. damn.blend (760.3 KB)

Using an environment texture node instead of an image texture one.
Then select all your sphere faces in edit mode, press U and select sphere projection.

In the UV map edition window you select all faces and scale everything up by to on the X axis.

It will not matter if the island is not perfectly centered on the x axis.

It’s easy to redo it, just make a cylinder, remove the caps, add a vertical seam to the middle then uv unwrap it. Scale down the top loops with proportional editing, then round the whole thing with mesh to sphere.
cylinder-to-sphere.blend (332.6 KB)
By the way, you should pin the uv vertices so they don’t get twisted again.

this might help:

Using those Texture Co., Mapping, Image node settings, the texture is correctly displayed. But when I see the UV Editing tab, the selection is still wrong. So, if I set those nodes, the values we set in the UV Editing are ignored?

Also, why did Blender display the correct texture initially in the first screenshot? I did not use any node or any settings; Blender just chose that way, and why it cannot be called again?

1 Like

Yeah, you don’t always need to use UV mapping. By using the nodes like this, you don’t need to worry about UVs.

As for why it worked originally, the clues in the name: UV Sphere. I think all of blenders primitives are pre-UV mapped, which can be super useful, especially for something relatively simple like…a sphere :smiley:

you need to select a image AFTER you run the “sphere projection”
not before

now there will be a very small artifact at the pole , there are ways to remove that but most of the time it is really not needed

If you use environment texture instead of image texture you have no artifacts.