How to output edited video?

I have rendered animations and images. But never needed to color correct existing video.
It’s all done and ready to output into a MPEG file.
How to do that?

Thanks guys,


Set the output settings in the Render / Output settings
Press the Animation button to render

In Render / Post Processing ensure you have ‘Compositing’ enabled to render from the node editor and/or ‘Sequencer’ to render from the Video Editor

You are just rendering an animation except you are not rendering from the viewport

ensure you have ‘Compositing’ enabled
I knew this but it had been so long.
Thank you for refreshing my memory Richard! Very kind! :slight_smile:


Mmm, I guess that was not enough :frowning:
I am only getting a file with this name: 01_color_corrected0001-0002.dvd
What is the general workflow to output a MPEG video file, from importing a MP4 video file into Blender, color correcting it, rotating it, and to finally outputting it?

I was advised to output to separate PNGs, then import them back in, into the VSE. Add the audio to it. Then output to a video format this time.
Unfortunately the audio is presently part of a MPEG video file :frowning:

So you have a MPEG4 video that needs color correction, you import it, fix it up, and now need to add audio and export to MPEG2?

Are you making a DVD? If so, you will need to render audio and video separately. Render both in MPEG-2 and audio usually needs to be at 48000hz to prevent re-encoding.

When you write MPEG in a post, always be sure to specify between MPEG4 and MPEG2, as they are very, very different.

“I was advised to output to separate PNGs, then import them back in, into the VSE.”

If your original content is already rendered/live action, I have no idea why you would do this. Just delete the audio from the featured video and delete the video from the featured audio and place them on top of each other.

Thanks so much for replying.

Yes, I am intending to burn a DVD with this video.
It’s good to know about the difference between MPEG file types. Now that I had a closer look I see it’s an MPEG4 (mp4).

… I have no idea why you would do this.

That would be simply because the original could use colour correction, and be rotated (it was shot vertically with a cellphone).

Just delete the audio from the featured video and…

And how exactly is this done?
Is it by importing the video into VSE, then once there I’ll be able to select each?

I think I’ve gotten the gist of what exactly you’re trying to do, but I’m still not sure what’s hanging you up, so I made a video walk through that goes over every step in detail.

This is Sooooo amazing of you to do! :slight_smile:
Thank you kindly!
I can’t wait to go over it :slight_smile:

I saw your video (finally).
I used what you showed in your video, and everything is way better now! (thanks to you).
I selected AVI, and I did a render using the Animation button in the Render tab (Ctrl F12). It created the file, but without audio.
How can this be fixed?
I am bringing the these video files to MS Movie Maker.
Thanks in advance

Would you mind upload a screenshot of your render settings? Make sure you have an audio encoding selected.

Should you need any other settings let me know.


I’m sorry, I should have definitely specified for the “Output” and “Encoding” panels which are below “Dimensions”.

I added the new image to the previous post.
But I didn’t see Encoding :frowning:

Ooh. OK. AVI JPEG doesn’t contain audio. If you want audio you need to select a format from the output menu that gives you an “Encoding” box with an audio section. Here are a couple of examples that should work. The first is going to give you .avi file if you like that (I tested it on WMP with a minor issue but it played fine on VLC), and following that is my personal favorite that should really work for anything.

If neither of these give you what you want, just experiment around with different combinations. And if you’re still interested in this stuff, this article will help you better understand what all the codecs and formats actually mean.

Almost there!

Finally got it! :slight_smile:
I am using Xvid + MP3.

Thank you so much for your help amprod2! :slight_smile: