How to play an loc/rot animation with a armature animation on the same object.

Im trying to make this work for hours and nothing seem to work, I have an armature that have two animations, one action and one f-curve type animation(loc/rot of the object), ok this two animations should run at the same time but the action(I really dont like the idead that everything is an action now), that is the bones animation goes from 0 to 40 on the timeline and I have another animation that is the position rotation animation that starts on 0 and ends on 520, those two animations should loop the end. but I tried to change th and the other on te layers and both animtions dont play.

This is a problem of the 2.62 version, can someone help?
This problems are…

Here is the image of the setup, its very simple.
Uploaded with

From my memory you have to use different Layers - I saw Monster comment something about them. Unfortunately I can’t really help, only give guidance.

Im using different layers, but it doesnt work, there is another that Im having, but with actions that overlap, like I have a stand animation, a walking and a running animation, but I cant make them blend properly, if I m withou press any button it runs the stand animation, then I press forward and it starts to walk forward and there is a good blending between them, then I hold shift and it start to run, and the blend between them is good, but but if I stop pressing shift the animation back to the walking animation is in a single chopped movement and the same happens when I try to go back to stand position, i think taht should be a tutorial or something about this new system compared to the old one, because to me is terrible.

Thanks ross

Theoretically they both should run parallel as the do not share a channel.


I tested a bit. It looks like the different actions mess up when applied to different ActionActuators.

While the Armature action plays fine, the object actions do not run at all.

Mysterious: The object action influences further game engine runs. The object starts with a different pose even if it should not play at all.

I can’t really nail it down, but there seems to be a problem.

As a workaround I recommend:

  • Parent the armature to another object.
  • Play Armature Actions at the armature
  • Play the Object Actions at the parent

Thanks mosnter, isnt is that really ridiculous, I tried to parent it to a empty but weirdly the postition changes even with no animations running, dam, I think that this fish ll be out of the demo then, thaks monster and sorry about the trouble.

This 2.62 version is way more bugged than the version that I was using and that was the 2.57 that suposed to be unstable, but I could work with all the animations without a problem, now I allready found two 3 blender bugs that cant be solve them well, there is a problem with the states when you are using multiple layers animations, there is a problem, somethimes the animation dont play untill the end and if you have a property it doesnt may not work, its tragicly unstable somethimes, its weird I dont know if the problem is on the states or with the animations but somethimes, from nothing it simply dont play even with keyboards or mouse sensors.

I dont know its hard to work with this.

also with 2.60, seem impossible…
without using a other object