How to prevent a bone from deforming the mesh

Hi there.

My problem is that when connecting the bones with the mesh, one of the fins gets deformed. The other three fins move well, they don’t deform, but the first one (the one you see in the image) deforms. I thought it was an influence problem, but the mesh is completely red.

Does anyone know how to connect a bone to a mesh and that when I move the bone, the mesh does not deform, but does rotate?


By “deform”, do you mean that it rotates a little bit at the beginning, but fully at the end?

If you want it to rotate fully throughout, remove weights to all other bones on its vertices and assign all vertices to its fin bone at strength 1.0.

1 Like

Quick 'n dirty solution (without deleting vertex groups and no deforming of bone for other objects):
1.- Select the object and then select the armature.
2.- In Pose Mode, select the bone and with Ctrl+P >Set Parent To Bone.
3.- Uncheck Deform in the bone properties panel.

Hope it helps.

Could you please share the object with its armature?

Okay, this is going to look funny. The problem was that the bone had two “Segments” in the “Bendy Bones” option. I change it to 1 and the mesh no longer deforms.

Thank you very much to all.