How to remove animation strip

I have 5 animation strips?if thats the right term?
A main strip and then 4 others that i imported from previous blender model.

To clarify I made seperate animations and saved as blend file but then decided to put them all on one animation strip so i imported the anims into my main blend file and copied them into the main strip.But now i want to get rid of these individual strips how can i do this?

I tried removing users and pressing the x(similar to how images can be removed) but it did not remove them.?
Any clue

You can just RMB click on a strip and hit delete.

hi Ant
Wasn’t sure how to explain it so here’s a pic.I only want to keep the first armature and delete the other 6 entirely right clicking the names does nothing so maybe you thinking i meant something else?

To clarify the terms, these are “Actions”. “Strips” are in the NLA Editor.
If you hit the X and it does not delete them, they have a user somewhere - probably in the NLA Editor since Blender can create those automatically sometimes.
Try to hit the X while holding Shift to automatically remove it from all users. You can see if it worked when theres a zero next to the name in the list. If thats not the case, open the NLA Editor and remove all strips that use the action manually. If that worked and you see the zero next to the name, save and restart Blender, it should be gone now.

try running this from the text editor and then check to see if there is a zero in front of the action name, make a backup first and I’m not responsible for any unwanted effects!!

import bpy

for object in
    if object.type != 'ARMATURE':
        if object.animation_data != None:
            object.animation_data.action = None
for nlatrack in bpy.context.object.animation_data.nla_tracks:

Thx will give them a try.

When you delete something in Blender, it doesn’t always get removed the first time or two. To make sure it is, save the file after the delete and then reload it, and then check in the Outliner for orphaned data.

Nothing worked:( so i instead exported the model as a fbx then reimported this model into new scene appended the armature and single action i needed from the blendfile.applied armature on the fbx so i could delete the fbx armature but maintain the weightpaint(then caused the model scale and rotation to change) so rescaled the model to fit the blend armature reparented with empty groups and seems to work.fingers crossed.