How to scale global physic simulation?

Hi i have 3d camera tracked in Nuke and i exported to fbx. I want to import this fbx into Blender and apply physic simulation. I have some problems here :

  1. I use fbx import command in blender, but this importer has problem , i never get the correct Y rotation ( the Y rotation is always inversed). Anyone know how to fix this ?

  2. I end up using a script
    It works fine and It fixes the rotation issues but the problem is : when importing , i can’t adjust the scale of the scene. So all the objects came from Nuke is 1/100 smaller in Blender. In this case , of course all the physic simulation will fail. How can i scale up the scene correctly including all the camera animation? i can’t just simply select all and scale up , because the animation won’t scale up. I need to scale the scene by 100x for physic simulation to work. How can i do this ? i tried to alter the ‘unit scale’ in the scene parameter but has no effects. Does anyone here know how to solve it ?


I think… when importing your FBX you open up the left panel and look bottom left, you’ll find a panel of options when importing an FBX. With a bit of experimentation, you may find the solutions to your scaling and rotation problems here.

Yes, i used that parameter but none of them can give me the correct orientation.

Can you parent all the unparented objects to an empty (you’ll see these in the outliner)… then rotate and scale the empty?

I find a way to fix the rotation , this is my setup in fbx parameter : turn on manual orientation and set forwar to -Z forward and up to Y up. Then DO NOT use the camera directly , but used it as reference only. Create a new camera, go to constraint property and choose ‘child of’ and select the original camera as parent. now clear out all translation/rot/scale of the new camera and set X and Z rotation to 180. Now if i see through the camera, it will fix the problem.