How to scale multiple files to the same size


I have the following problem, apart form not actually being a blender-user. I have a number of 3D-objects in a CAD-format. I need them in obj-format for a viewer. I exported them as stl-files and used blender to convert them. First I noticed that I had to move the imported part to center the origin for the rotation in the viewer. Now I also need to scale the files in such a fashion that they look good in the viewer window, i.e. not too small but not larger than the viewer window.

As it is now, I would need to open a file, scale it by a guessed value, export it as obj, reload the viewer and check the size. Repeat as necessary. I wonder whether it would be possible to somehow scale it to a certain value or size on some absolute scale, so I would not have to scale by trail and error.

I hope I made myself clear as far as problem and question are concerned. Also, I did search, and I do hope this is the right place.

Thanks in advance,

If I got you correctly, you have bunch of files which are getting imported from obj with wrong scale.
If so, there are various ways of dealing with this:

  1. You can scale each imported object manually, after importing, just press S and then .5, and enter to scale down, or S,2,enter to scale up.
    Then you can apply scale by pressing Ctrl+A(im not sure about this shorcut because I have most of them customized) and select scale(or size)

  2. When you open import obj view there’s a pane by default on the left, if you scroll it all the way down, you’ll get settings for obj importing, and there a Clamp Size value, so set it to 2 if you want to scale up you obj two times, or 0.5 to scale down.

  3. Or you can automate previous way, by opening User Preferences->Input and looking for obj import (it its there, again, Im using so many customized things and got so used to them, that Im not sure whether they custom or standard), anyway, if there’s no such thing, you can add you custom one, I’ll attach a screenshot. The thing is there’s clamp value in it too. And if you set it so something other then standard - it will be used as default, each time you press OBJ IMPORT shortcut

  4. You can always create a python script if you have to same things again and again for each file

As for resetting movement, you can use ALT+G to clear transition. And if it doesn’t help, then Set Origin->Origin to geometry and only then reset transition.
And I didn’t really got why you need to open, scale, export then repeat if necessary. BTW if you have problems with rotation, try also changing forward and up axises in obj importing settings

Thanks you for the replies. I found them very helpful as far as my workflow is concerned[B], and it made my job a lot easier. [B]

The reason for open-scale-export-repeat is that the source parts are of different sizes (from the CAD-software), and I do not have a single value to scale by in order to make them fit into the viewer’s window. So I need to “guess”, check it in the viewer and if necessary guess again.

Now I have set up a php-script to save me from the hassle of copying and renaming, thus cutting down on the work required. Between that and your suggestions, I will be able to get this done within a few days - thanks again :).

select object in viewport using the keypad key dot .
it will bring the object to fill up the viewport but no scaling here only viewport zoom adjust!