How to show polygons


I checked wireframe to make polygons visible but that part of the polygons that were created by filling curve contour doesn’t show polygons

How to show polygons on all surface of the model

How_to_show_polygons_0001.blend (1.6 MB)


It is one big polygon. There are no others. You can see it right in the counters, select 1 face of xxxxx.
Recreate it with much much lesser edges and try a subdivision modifier.

Thanks to your reply

It is not so - it is not one polygon coz initially when it was just 1 big polygon it looked broken but after i subdivided it 5 times then i became smooth. In modo indi - there is a tool that freeze all invisible geometry to make it visible. Look at the picture:

The roughest red line is zero level of subdivision, the second red line is 1th level of sudivisionm and so on. Green arrow shows show this polygons deformation during subdividing and becoming smooth comletely made by 5 subdividings

I manipulated with shading to show you inside-subpolygons:

How can i freeze geometry in blender 2.8?

It looks like you are working with a nurbs object. I don’t mess with those too much, but I guess it has trouble displaying that surface because it’s not a normal mesh (blender doesn’t have as many features when it comes to nurbs or curves).

You can convert the nurb into a normal mesh (Object menu > Convert to > Mesh from curb) but that switches from editing the object as a curve to editing it as a mesh.

Thanks for reply

I drew a path contour then converted it to mesh and pressed “F” - button to get many subpolygons inside one but failed

I need next result:

How to fill curve/bezier/path-closed-contour with polygons?

The F command just fills with one face. In this case it would produce an ngon. Alt + F would fill it with more than one face, but they would be triangles.

To get the result you showed me, you’ll have to select the top edgeloop, then use the grid fill command (Face menu > Grid Fill). The options for it appear in the bottom left corner of the 3d view after you activate it.


Make sure to also check All Edges in Viewport Display to see them all. It’s off by default because displaying all edges of a very dense mesh might be slow.

Thanks for helpings!

When i switch on wireframe - yes, i got visuality of the “polygons”
But there is no any possibility to see influencing of “All edges”

I don’t know if I get your meaning - your object has indeed large ngons at top and bottom, as rigoletto said. Those don’t have anymore edges.

What I wanted to show you is this setting, see picture. Those two cubes have identical geometry. Only one shows all edges. It doesn’t help with your mesh, though, because of the ngons. I just wanted you to know about this setting.

Thank youto your reply

I tried to reproduced it and failed.
I created a cube then made bevel on all edges and switch “All edges” on and got nothing.
What i did wrong?
"Where did you get the second cube? :slight_smile: "
Can you upload your blender file?

Sure, attached. I pinned the two properties panels (pin icon top right) so they stay regardless of selection. Unpin them for normal operation.

all-edges.blend (234.7 KB)

In your image: if you beveled the edges, it looks correct. You don’t get edges inside faces when you bevel. What I did was add two subsurf modifiers to get the rounded edges and extra mesh resolution, then applied them. The second cube was simply duplicated.

Tanks for file

Unfortunately there is no any possibility to understand your explanation
There is no any subsurf modifier in modofier folder
I reproduced all actions you listed - added a box, subdivided it using 2 subdivision surface modifiers and got a sphere!
Using “wireframe” checkbox i did all polygons visible and switching “all edges” on did nothing

As I said, I applied the modifiers, so they are not present anymore. I used them only to get the mesh geometry, to illustrate what “Show All Edges” does. If you want to recreate the rounded cube, here are the settings:


I already have done it, before your last message

That what you have shown to me in last screenshot doesn’t differ from that what i did
Two allpied modofiers…

When i check on “Wireframe” than i can see geometry polygons
When i switch on “All edges” then occurs nothing with “wireframe” switched on and with switched off

Alas, using this example - there is no possibility to demonstrate how “All edges” works

You’re right, with Blender’s default settings it does nothing, my mistake for not checking earlier, sorry. I have a customized startup file where I set the wireframe slider in viewport overlays to 0.5, see image. It seems to be at 1 by default now, showing always all edges regardless of the All Edges settings in properties.

Why we now have two wire edges settings, one in overlay and one in properties, I don’t know.


The settings in the header are global, but the wireframe setting in the object properties is on a per object basis.

1 Like

Of course!

Oh dear. I seem to have been sleeping already yesterday. Thanks!

Thank you that you investegated this task to the end

You’re welcome. :slight_smile: