How to tell HDRI lighting to just light 1 object, not entire scene

So I know how I can stop lights from emitting on specifics objects (with render layers)

But this is a somewhat different problem… I have HDRI lightting that im using to light an object. However… I only want the HDRI to light (and show reflections) on a certain object.

I dont want the HDRI to light, or show reflections on the floor…

How can I achieve this?

Here is the simplified blend file.

I think the easiest way is to use 2 scenes, as hdri’s are scene wide. Make a copy of the scene and disable the hdri, and hide the sphere. enable ‘tranparent’ so you can alpha over the sphere, and then render both scenes and composite. There’s other ugly hacks I can think of, one involves render layers and a big cube around the scene.