How to turn off anti-aliasing options in Eevee

I turned off the anti-aliasing option in the render tab in BI to get a sharp edge from the color ramp node.
Source images without anti-aliasing are essential in the Japanese 2D animation industry.

But I don’t know where those options are in Eevee.

Do you know how to turn off anti-aliasing in the Constant option of a color ramp node node at Eevee?
Thank you in advance.

Try the Render tab > Film > Width > set it to 0.
Can also try turning down your render samples.

This is from Cycles but may be shared by Eevee.

1 Like

Obviously, anti-aliasing of object silhouettes will be removed if i adjust the options as you say.
However, anti-aliasing of the color ramp remains intact. Adjusting the render sample value was also useless.

You’re the one that ticked those object boundaries…

color ramp should be constant, or use greater than math node and a mix rgb.

Here are the material node trees I used for each engine.

Emission causes antialiasing. I am suprised as of why you´d want that jagged effect on the ramps (other than apply an overall “smooth” filter to the entire finished frame after compositing and effects.)
If you use Strenght to 0.1 but raise the light power could give you a jagged effect. Also try lowering the shadow map all you can. Because (remember the shadow that casts the light is your lower color on the ramp), is represented as shadow.
Lower all light bounces on Diffuse to 1. That could also help. Also don´t use gaussian as pixel filter antialiasing. Obviously you want the other (the FILM parameter on Render, use BOX filter).
Sorry gotta unlog. Reply to this to send you more screencaps and a complete reply. I´m all NPR.

This is because the color ramp and curve nodes are converted to textures for performance reason (it has always been the case even in the old GLSL viewport). And theses textures have linear interpolation enabled so if you zoom closely you can see the interpolation on the 1x128 ramp texture.

To workaround this, use a math node with a mix node as @Daedalus_MDW suggested.

That said I think we could at least use nearest filtering if using constant interpolation for the color ramp node.

I hope you understand my lack of knowledge.
I don’t know how to use math, mix nodes.
This is my best. Of course, constant interpolation doesn’t work properly.

I would appreciate it if you could tell me how to use math and mix nodes for constant interpolation.

2.80.blend (479.7 KB)

I’ve attached the blend file with the render settings screenshot (plz click).
I’ve looked at the render settings as much as I can, but the constant interpolation failed.

You need to replace the color ramp by the greater than node and that’s it. the second value of the math node is where the cut happen. in other words, it’s the color stop position.

Thank you for your explanation.
Without knowing computer graphics, I could not imagine using a Greater Than node instead of a ColorRamp.
I just did the habits of BI.

As you said, I entered the Math node with the Grater Than option as the factor for the Mix node, and constant interpolation works well.

F12 rendering works just as well.

I have achieved what I want.
Thank you again.


I attach an image of the node tree representing multiple gradations in both engines.
The Eevee side tends to be more complex, but it can be handy if you cover it into a node group.

I don’t know much about Blender programming, so I am cautious about the comments, this is my wish I would like Eevee to be able to use the ColorRamp to express constant interpolation. :slight_smile:

1 Like

I just commited the color ramp constant interpolation fix. It should be in the next nightly.


In the composite part of the Japanese 2D animation pipeline, the after effects are standard. And most effect plug-ins for cell animation are designed to work with images that do not have anti-aliasing. We finally use the anti-aliasing effect to smooth the image.
Take a look at the plug-ins created by Psoft in the links below. You will see why the Japanese 2D animation industry needs images that don’t have anti-aliasing.