Human model Rigging: unable to move after parenting

I imported a .Obj file which contains a 3D human type model into Blender. I’m trying rigging.
Added the default Armature for human. As I don’t want complex bones at hand and foot, deleted those bones and made it simple. Please see the attached .blend file.

I tried to do PARENTING. To make sure the parenting stuff works properly, I tried to MOVE/ROTATE.
But the mesh and/or bones not moving.
I tried that CTRL+P stuff too for weighting …but no luck…

What could be the problem ?
Thanks in advance.

First.blend (1.17 MB)

The reason you can’t move anything is that you’ve turned on Manipulate Center Points. Turn this off.

(picture is from someone else’s file, but same problem)

You’ve also used the Rigify Metarig as your armature. This is incorrect. The purpose of the Metarig is to be a template for generating the Rigify Armature, which is completely different. You should not try to use the Metarig for your character. Go watch some tutorials on using Rigify before you go any further. You’ll save yourself a lot of trouble and annoyance.