I accidentally disabled rotation and scale from keyboard

i found this post https://blender.stackexchange.com/questions/42830/rotation-and-scale-have-suddenly-stopped-working
but i can’t find that button with left and right facing arrows and 3 dots anywhere?

any ideas?


It would seem that in modern versions it’s probably this checkbox:
Active Tool and Workspace settings (or N-panel > Tools) > Options > Transform > Affect Only: Locations

awesome, that was driving me nuts. my #1 complaint about blender is how easy it is to put it into a weird mode without knowing why, then have no idea how to get out of it (other than asking for help here!)