I can't fade a particle texture

I have an emitter and i gave the particles a cloud texture. I turned on the alpha value in the map to settings. I want to have the texture fade out, so i turned the alpha down and the Var. down. This works fine for what i want, but as soon as i keyframe it the alpha seems to have absolutely no affect. I removed the keyframes and i can fade it in and out again.

What should i do?

I really appreciate any help. I’ve been going crazy over something that should be pretty simple.

Just btw.: You could set the map to type to multiply. That way you only need to lower the alpha value of the material to make it fade out.

What particle visualization are you using? I tried to fade out billboards once and I failed, too, because it seems they take the global time and not the local time. With halos it seems to work well… but that’s probably not what you want.

Good to know, thanks. Uhmm, i’m using points. That’s what you were asking right? I don’t know what you mean global time or local time. I’ve attached the .blend. I"m just trying to get it to look like flower or something exploding out. I haven’t done very much with particles, or anything for that matter. I haven’t changed the texture blending mode or anything.

The file was too big, so i erased a bunch of stuff actually. It’s just the particles now. It starts on frame one. The alpha and var are key framed on 20 and fade out until 51.

Try these settings:

  • start over or undo ALL changes made to the material settings
  • set the material’s diffuse color to white
  • add basic cloud texture
  • turn on ztransp, leave alpha slider at 1
  • on the Map To panel, enable Alpha, set Col to desired color, set Dvar to zero
  • at this point you should be able to adjust the Alpha slider to see the fade effect in the preview
  • animate the Alpha slider’s value

I’ve also got a video tutorial that demonstrates how to control the alpha value of billboards on a per-particle basis, relative to their lifespan. It’s the “Magic Wand…” tutorial at cgcookie.com.

Hey, thanks. Unfortunately i tried and it still doesn’t work. I have no idea what’s going on. I tried it once and it worked; i forgot to save though. I tried it again, this time in blender 2.46 instead of 2.49. I’m actually working in 2.46 with the project. I’m not hooked up to the internet on the computer that i do my work on, so i don’t update as regularly. The version shouldn’t be the problem though, right? Anyway, i tried it in 2.46, after completely deleting th object and creating a new particle system and material. The alpha affects it when i render a single frame, but as soon as i key frame it to make an animation, nothing happens. i took the key frames out and it works again. I am confused.

By the way, I watched part one of your tutorial and got halfway through part 2. I didn’t have time to finish, but your tutorials are very thorough. Definitely the best i’ve seen. I learned a bunch of little stuff aside from the main part of the tutorial that, makes using blender now so much more efficient. Like when you move the cursor to the selection. I knew how to do vice versa, but i needed to do it the other way so many times. I would just zoom in all the way and get the cursor as close as i could to the center. What a pain.

The version you’re using may be a significant issue because the particles system has changed quite a bit.


In any case. I have no idea why it worked that one time, it still doesn’t work even in the newer version. I swear, it’s as soon as i key frame it. There are no problems before hand. Once i get rid of the keyframes, the alpha is functional again. Everything looks as it should in the IPO curve editor as well.

can you post a blend file, or screenshots of your settings?

Any suggestions on how i can get it small enough. Even after deleting everything except the emitter object and turning the amount of particles down to 500, it’s still too big.

Try creating a new blend file and creating the particles system on a plane object. This might also help to reveal if there’s something else in your original scene that’s keeping you from getting the results you want. Sometimes conflicting settings can creep into a scene, especially when trying to resolve a problem.

I have no idea what was going on. I created a completely new scene. It finally worked, but i had to set the particles emitter to start at frame one. I had all the settings that i could think of set to the right frames, emitter, bake, render. It seems that after i set it to emit at frames above 100 that the alpha wouldn’t affect it once i key framed it, but it did in the preview. Does that make sense?

Exactly what are you keyframing? Also, try freeing and re-baking the particles. It’s really hard to know what the issue may be without knowing all of your settings because there may multiple issues.

I’m just key framing the alpha. I didn’t actually bake the particles, i just noticed that, if the end frame was lower than when the particles would die out, the animation would cut off. I’ll try posting some settings later. I couldn’t post the actual file even with very minimal particles, because it was too big.

Particles are weird when it comes to IPOs. They use the frame number as a percentage, which is different compared to every other object in Blender. So frames 0-100 represent the life of the particle, not the keyframes themselves.

You can take a look at my 3d stroke file here:

Maybe it will help, but if I remember right, the BLEND file does make use of the 0-100 percentage in the IPO.

Sorry about that stroke file, I meant the 3DS Max super-spray emulator:

Finally. I don’t know why the other files ended up being so big. Here it is. Fading out the alpha worked fine when i started the animation on frame 1. I started this animation on frame 100 and the alpha doesn’t affect it.

The spray thing was cool, but i didn’t know how to apply it to this.


Flour Explosion.blend (379 KB)