I can't move objects anymore!

Hi everybody.
I have an issue I can’t figure out: I can’t either translate, rotate or scale objects by pressing shortkeys G, R and S. The function activates, I’m sure (mouse shape changes), but objects remain where they are. I can move objects only by inserting numerical values.
How can I fix that?

Have you by any chance set the locks on objects? You can make them either “unselectable” in the Outline View or else hit the padlock icons beside the attributes in the properties view of the object. Another thought is that maybe you have set a key frame in animation.

My first check would be that they are or are not selectable from the Outline View settings. Can you move objects in a new .blend file or is it all .blend files that are giving issues?

Neil

They are selectable and there isn’t any frame. I have the same issue with new .blend files. :frowning:

If u downloaded the newest version of blender u have to run as administrator…or at least it makes me do that…if I dont run as admin I have no controls at all

Of course I run it as administrator. Well, anyway I solved the problem re-installing Blender -.-’

1 Like

I was having the same issue, my SNAPPING TOOL was ON…When i turned it OFF everything was FINE…
Hope this will help you

2 Likes

How do you sign in as an admin because I’m new to blender and I can’t keep edits or move objects.

This happened to me when I disabled a shortcut, but I have a very customized setup:

I use Left Select:

Blender User Preferences --> Input Tab:
left

And I had disabled the following shortcut:

3d%20manipulator%20shortcut

Then the translate manipulator would appear but I could not move objects by dragging the mouse. When I re-enabled the shortcut, I could move them again.

Perhaps you have Snap during transform enabled and are working with a small (relative to snap) model? Try either disabling snap by clicking the magnet icon (shift+tab) or changing the snap settings to better suit your work.

This worked like a charm.

So if you run into this in 2019, maybe, just maybe its under the tool tab of n or t. With checks on ‘affect only’; transforms. Well it did it for me!