I cant run the blender executable with ubuntu

ive downloaded th linux version of blender un packed the file and tried to run the executable and … nothing. What program to i need to download to run and application/x-executable

What program to i need to download to run and application/x-executable

Download, extract, get into the extracted folder & double click blender is all I have to do to fire it up on Ubuntu. Which ubuntu do you have & which .bz2 file did you get from blender.org?

Also, if you’re looking for ‘the get blender working as quickly as possible’ option, open a terminal and type:
sudo apt-get install blender

It’ll ask you for your password, then install Blender 2.62 (I believe). Ubuntu doesn’t stay up with the latest blender, but it’ll work.

todd

ya ive tried the first option and when i dobble click it brings up an error message saying it could not open it. what drivers do i need to run the file?

ill try the second option

second option is brilliant! its 2.63.id still like to update at some point so id still like to work this out. why cant i run it?

Well, give the 2nd option a go & see what happens.

On the first option, there are 4 different .bz2 files you can get from blender.org. There are 2 different archictectures (32 bit and 64 bit), and 2 different graphics libraries. You first have to know if you’re running 64 bit or 32 bit. You can find that out from the terminal by typing:
uname -a

That will give you a line that looks like this:
Linux bork-laptop 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

That x86_64 bit means it’s a 64 bit OS. (Yours might say x86_32 or something to that effect). So, I’d be after the 64 bit blender.

Type this into the terminal:
apt-cache show libc6 | grep Provides

and it’ll return something like this:
Provides: glibc-2.13-1

That means my machine as the 2.13 version of glibc. Blender’s is 2.11 & they’re compatible, so I want the 2.11 version of blender. Besides, I think the last version of Ubuntu to use the 2.7 glibc was Ubuntu 8.04 which was quite a while ago.

Anyway, 64bit 2.13 glibc means I’m gunning for the newer 64 bit version of blender from the download page.

todd

Glad it’s working. If you figure out the 1st option, you don’t necessarily have to remove the blender version that was installed through apt. But, it might be wise to stick with one or the other just so your .blend files are created from the same version. If you keep both, your blender icons on your desktop & menus will point to the 2.63 version from apt.

To use 2.65a, you’d have to download the .bz2 file, extract it, then browse (through the files window) to the extracted folder & click the blender in there to get 2.65 running. If you get that to work, then I’d:
sudo apt-get autoremove blender
to lose the 2.63 version, and make sure all your .blend date is from 2.65a.

todd

Yes Im sure that i have the correct blender for my computer, and ive succesfuly un packed it it should be good to go, its as if ubuntu dosent recognise the file type. Browsing the internet i found that it is a ‘mime’ type…

in the blender wici it says to make sure im running x.org which a quick look in the software sorces tab in the settings tells me that i am. I tried re-downloading… no good… It should work…

Anything i might be missing

Not that I could tell without sitting at your machine :slight_smile: Try watching dmesg from the terminal & see if it lists any oopsies when you attempt to start 2.65. It might give you a clue or two to chase down.:
sudo tail -f /var/log/dmesg

todd

double-clicking has never worked for me. Try navigating to it in the terminal and simply typing ‘./blender’ without the single quotes. If nothing else, you’ll get a readout of the errors that are preventing it from running.

try installing libsdl, this solved the issue for me in xubuntu.

sudo apt-get install libsdl1.2debian

Try the following link on how to get the latest blender installed http://blog.scrapperduncan.com/2011/05/17/how-to-install-blender-2-5-2-57b-on-ubuntu-11-04-the-natty-narwhal/ I was hoping for some insight in to why I can’t get the buildbot version I’ve downloaded to work. I did get some insights - thanks to posters; so I am now sure I was using the correct tar file.

I tried your suggestion and it says ‘permission denied’

permissions suck sometimes…

sudo chmod +x blender
from the same folder it’s in

or
sudo chown user:user blender

with user being your user name before the @ in terminal. So if this is what terminal says:
[email protected]:~/blender-2.65a-linux-glibc211-x86_64$

Then

sudo chown bill:bill blender

todd

ok suddunly it works, i draged it into comand line and pressed enter and it shows up and now double clicking will work. hope it will be this easy for other people.