I can't see anything in camera view

Hello,

As the title already say’s, I can’t see anything when I switch to camera view ( with zero on the numpad ).

I can’t figure out what is wrong.

  • when I go in camera mode all I see are the X, Y and Z axis manipulator from the camera
  • I can see the camera in all the other views ( so I did not hide it with “H” )
  • when I hit F12 it will still render the image

I tried deleting it and adding a new camera but this gives the same problem. This makes me think that I have accidentally changed a setting, but I don’t know which one.
Does someone know how to fix this?

How far is your camera set away from what you are trying to view? Check your clipping settings for the camera. Also check the display settings and check to see what you have checked or unchecked for what to view.


Uncheck only render if it is checked

Is that image in camera view? I get exactly the same result, I also don’t see the grid when in camera view.
So how did you do it ( because I don’t know how to re-produce this error with a new scene ) and - more important - how can I undo it?

I did try all the things in the N display panel but without any luck.
My clipping settings are set to “start 0.100” and “end 1000”.

Edit: I know see that you have “Only Render” enabled, I have this disabled.

@jovlem also check your actual camera clipping on the actual camera settings not just the display settings. As that will also need adjusted. By default I believe the max clip is set to 100 if it is set too low you will not see anything not even the grid floor. Select your camera in the outliner and then click the camera icon and check it’s settings as well.

First image shows the default other than the display rendered (which only shows in the viewport what is actually going to be rendered)


This image is where to set the physical camera settings where you can check clipping there as it will also produce a blank view through the camera if it is set too low.


1 Like

Thank you but I already tried this.
But when I hit F12 the camera will still render, the only problem is that I can’t get a preview of it.

Oh, and I also can’t see the camera’s borders when in camera view ( scrolling in or out won’t help ).
I remember that I did try to set the camera to “Orthographic” and tried some settings there. Can that be the problem? Now I have set it back to “Perspective” but it doesn’t matter…?

Does it do this when starting a new project? Or is it just the project you are working on? I am scratching my head here trying to think of anything else it could be. If I think of anything else I will post it but right now I am at a loss :frowning: sorry Maybe one of the other more avid blender pros will chime in and get it straightened out for yours and my sake.

Oh dear. Another guessing game thread…
Please ALWAYS supply an example .blend file with any support question. All your answers are in there.

By not doing so you’re forcing us all into a tiresome routine where we have nothing to work with and need to worm every tiny bit of information out of you. I think it’s safe to assume that many “avid Blender pros” neither have the time, nor the patience for that.

Here is the blend file.

Attachments

camera error.blend (495 KB)

Start Blender.
Click File > Open to open your file.
In the “Open File” dialogue screen, uncheck “Load UI” (left hand panel).
After that the file works as expected.

Even before that, the “Default” screen layout was the only one acting up - in all others the camera view worked just fine. Not sure which setting actually caused this: Might as well be some Blender viewport hiccup that got saved into your sceen layout.

1 Like

Thank you for clearing that up for me. I had no clue especially when I had that blend file open in one screen and opened up a new one on my other screen and was comparing settings and all were pretty much the same other than no light being in the provided blend. Allows me to be able to sleep now.

2 Likes

Camera view, home key. The view is panned somewhere.

10 Likes

Thank you, it did the trick.

You are my hero, man. Thanks!

My god you save my life

@JA12
Thanks a lot man.

Oddly I have this coming up a few times with 2.93 /(.1)

@JA12 holy crap this saved me. Why is this happening in 2.93.x? This was happening even with totally new cameras.