I can't stop the game engine once i start it with latest blender on imac 27

I have been learning blender for about a week now, and i had gotten down the basics of
modeling, animation and rendering; but when i tried to apply some basic physics to a cube and a plane for testing then started the game engine. It ran through the physics and just froze in place when the cube finished it’s motion.
I couldn’t do anything else in the program. It was frozen. I had to Force-Quit Blender.

Basically i couldn’t pause it once i played it. And this is in the game engine.

I am running Blender 2.57b i386 on an iMac 27

Am i doing something wrong? Do i need to add some sort of start-stop parameters
to the game engine?
Do i have some setting wrong?

Do you have a keyboard sensor waiting for escape to be pressed? Its the only reason I can think of why you wouldn’t be able to quit. Maybe you tried to back out of setting the key for the sensor and pressed escape, have a look at all of them to make sure.

Yeah none of the keys work to get out of the game engine. not the “p” key or the “esc” key. I am pretty new to blender so i don’t know what you mean by sensor key.

You mean i have to change the key settings?
How and where do i do that?

But yeah, you do understand my problem.

Would it help to tell you that i downloaded an older version of blender?
Still the same problem.

I am not sure but i think that the key setting data may be stored outside of the “.app”
file; so downloading a new app wouldn’t make any difference.

But i should be able to change these settings right?

I am so stupid! It works when i press the “esc” key.
Thanks for your reply though.
I Thought i had already tried the “esc” key.

Problem solved.