I like to move object just a bit. But after pressing G, the up and right Arrow didn't work

Hi guys,

I’m a newbie in 3D and also in Blender from Indonesia. Now i’ve been studying the jeep tutorial by Chris Plush from CG Masters.

I have a bit of problem here. Btw i’m using blender 2.79b on my macbook retina.

Anyway the problem is In the tutorial i have to move a certain thing, usually vertex or edge for just a little bit by using G and then pressing the arrow keys.

But after pressing G, the right and up arrow didn’t work, does anybody know what’s going on? Any idea how to solve it?

Thank you,



After pressing g you are in “grab” mode. You can then press x,y or z to constrain the movement to an axis. Or you can press shift-x, shift-y or shift-z to constrain it to one of the planes.
There are other keys, too.


Thanks for the response @Lumpengnom but i think you are missing the point.

You also can use the arrow keys to move things in object or edit mode for a tiny bit, this i know from Chris Plush, he use it quite frequently in the Jeep tutorial.

And in my case, using macbook retina, why only the left and down arrows that worked?

Hey, I didn´t know that.
Anyway, it works on my Windows 10 for all arrows.
On my wifes mack book pro it is like on your mac. It only works with the left and down arrow so it seems to be a mac problem.

I didn’t know too, but I just tried on my mac and it works with every arrow, so it’s not a mac related issue; there must be some shortcut in the preference to properly settle.

Hi @sourvinos thanks for the response…

Here, i see some mac users also have the troubles with the arrow keys:


But i didn’t really know what killallDocks have to be applied to? Do you have any ideas?

Thanks anyway,


Open terminal and type killall Dock with the space in the middle. Type it exactly, with the first letter in Dock capitalized.

I have never had this problem on my macs, but there are different keyboards for different countries, and relative layouts, so who knows…

About blender behaviour, my guess is that you’ld have to change some settings on blender preferences, or possibly solve some conflicting shortcut assignements, I personally never modified arrows usage on my preferences.

Hi @vpanggabean1980, have you find a workaround ? or a solution ? I’ve exactly the same problemon my Mbp 2018, (kill the dock had no effect).


Pi : I’can’t reproduce this bug with 2.83 Alpha version.