I made an interesting Fake volume light :)


(Camos1011) #1

I’ve been messing around with low memory fake volume lighting for UPBGE.
I also wanted to share a non-GPU specific method.
I not only make the switch to UPBGE but, I’m now usin an AMD GPU now from an Nvidia.
AMDs don’t run certain graphic scripts so, I wanted to help out others with this issue.
All other posts on faking volumetric lighting seem to be outdated so, it forced me to make my own.

Fake Volume Light.blend (639.8 KB)

Suggestions on possibly making this one better would be great too if possible.


(leoskateman) #2

post some pictures so we can see


(Camos1011) #3

Oops!
Should have done that before.

It’s not perfect.
I’m still fine tuning the meshes until the lines are gone.
They definitely cast brilliant shadows and can be seen from every angle just about.


(Camos1011) #4

Here’s a slightly better update!


Fake Volume Light.blend (656.5 KB)


(Cotaks) #5

so many edges, why not just use a cone with an texture on it? the propeller would look better as well, it now has some sort of artifacts due to the tons of edges (i guess).


(mataii) #6

I think this is an interesting aproach :slight_smile:

This is how it looks, for thoose who did not download the file


(Camos1011) #7

Thanks!
The props aren’t mine though.
They were just to show the shadows.


(Camos1011) #8

For Shadow volume too.
A texture alone doesn’t give the same result.
This is also more for TPS/ Sidescroller type game for when characters pass through the light.
I’ve been tweaking the numbers of faces and experimenting with different geometry like the "X"s in the middle.

I just Edge ring select a ring and pull it out to find a clear face to delete them or edit them.


(Camos1011) #9

There I tweaked it to be slightly smoothed out.
I managed to lower the polys by half now by decimating it.
The shadows are darker now too until you enter the field of light now where it’s foggy.

Fake Volume Light lower poly.blend (638.8 KB)


(Camos1011) #10

I tweaked the Z-Offset and Depth Transparency and got kinda better results.


(Cotaks) #11

what i get if i hit play

ryzen 5 1600
sapphire rx 470 nitro+ OC 4GB
16GB ram
SSD


(Camos1011) #12

Oops!
I forgot to put it in fullscreen :confused:
Tried it in 1360 x 768 on an AMD A12-9720P Radeon R7, 4 Compute Cores 4C+8G DDR4.
Damn that’s better than my system and you still get that! WTH?
then, I raised it to 1920 x 1080 and it works perfectly.
Haven’t tried lower resolutions nor tweaked it in the engine resolution.

It works fine with very slightly lower resolutions than 1360 x 768 and have been testing it at near full screen so what’s the deal?
What do you reckons doing that?
That stinks.
Should have tested it better.
I’ll give it a further test.
I also upgraded my AMD drivers too and that helped a lot.


(Cotaks) #13

It can be amd itself, it’s well known that amd has some issues related to shaders as well.
but i have not encountered such a thing in all the years i use blender, so i really have no idea.


(Camos1011) #14

I think it’s an HDMI out issue.
Just tweaked and tested my settings.
I changed the Active Signal Resolution from 1366 x 768 to 1920 x “1080 (kind of obvious resolution standard)” at Desktop Resoltion at 1600 x 900,True Color (32 bit), 59 Hz (minimal) and Pixel Format of YCbCr 4:2:2 and the CPU works like under 1366 x 768 but, solves the problem completely.


(Camos1011) #15

Full Screen 1600 x 900

[Update] Now it glitchy in lower resolutions but, fine in full screen.

[Update] I changed the Desktop Resolution to 1920 x 1080, 32 Hz (Interlaced). and the problem is solved on both ends while keeping the CPU down.