I really need to COPY and PASTE from 2.79 to 2.8 and back

But all I get is an error " Clipboard is empty".
So what am I not doing right?

I want to be able to copy a mesh (dyntopo mesh) from 2.79 take it to 2.8 like I saw on the blender conference last year (work smartly not harder).

Select object>Control +C on 2.79
Open 2.8 CTRL+V.
Error “Clipboard empty”.

Please help.

Just tried here and having no problems.
Made a torus in 2.79, ctrl+c
Opened 2.80, ctrl+v, torus shows
Selected startup cube in 2.80, ctrl+c
Went back to opened 2.79, ctrl+v, cube shows up
So no problems coping and pasting back and forth.

I’ve seen others reporting this issue here at BA, but don’t know if the problems were solved.

Is this with current 2.80? There were substantial changes to how copy/paste works a few days ago.

Edit: Seems to work here as well for basic mesh object copy/paste both ways.

Also Dyntopo seems ok, and the object comes across with the Dyntopo on/off checkbox preserved.

Tried with 2.79a, and 2.79 experimental along with 2.80 master.

One thing that will cause this is if your two Blender versions are not using the same “Temp” file location. Check in Preferences in the File or File Paths section (2.79 and 2.80 respectively) and see if the Temp and Temporary Files locations are the same for each. That’s where the clipboard buffer file is located I believe, so the two versions need to share the same place.

1 Like

No, it’s not the latest, from 3/23, waiting for a bevel fix that was submitted for commit today, so will download latest tomorrow. I’ll check again to confirm.

Also, I always keep “Start Up” and “Preferences” exactly the same in 2.79b/nightly and 2.80, so TEMP files is in same location.

Can’t remember for sure, I think some here having issues using 3rd party clipboard OS addons. I know I’ve responded to a few post’s about this exact issue.
But I’ve not seen a issue marked SOLVED, or a reply with a fix.

1 Like

Have you tried rebooting your computer?
Sometimes something as simple as this will fix a problem.

Finally had a chance to download todays build to test again, still not having any problems with copy/paste between 2.79b and 2.80 like first test.

Would be nice if the OP would reply back with some kind of response!

Thank you. That might be why. I do have 2.79 onto one temp location and 2.8 left by default.

1 Like

Good to know, if I see others having the same issue, I’ll let them know that this could be a possible fix. Or mark this thread as “Solved”, if you find that setting both 2.79/2.80 to the same temp locations fixes the issue, that would be helpful to others.

I’ve been using copy/paste to go from 2.80 back to 2.79 because of not being able to open 2.80 in 2.79, it’s been working well. But it does not always work.
Hope this has been helpful.

I got a lot of addons on 2.79, using temporary files like this:

I run Blender 2.79.7 from an E:/ Drive.
I installed Blender 2.79b official to C:/program files//etc…
Maybe folders in that location are conflicting?
Because the Blender 2.79, when it runs, shows an incomplete mesh menu:

I have this problem with that particular menu since 2017. No one has been able to solve it.
So yeah, these are my configs on 2.79.

Blender 2.8 looks like this:

Now you´d think I can just copy/paste beetween 2.79 different window application instances, right? Wrong! Blender 2.79.7 running on the E drive (my daily developer version) cannot copy objects between window instances. So I cannot paste Blender 2.79 object to another window with Blender 2.79 3D view.

Any ideas?

It looks like your settings for Temp and Temporary Files match so from a Blender point of view it ought to work I think.

Do you have any fancy security/anti-virus software installed? In some cases I’ve seen Windows get weird about allowing Blender to write to arbitrary locations on the system, possibly based on whether you’re an ordinary user vs. administrator, 3rd party security software, or in highly managed corporate environments. Some times it makes a difference where/how Blender is installed (zip installer extracted somewhere random vs. the MSI installer putting the files in an official location on the machine that is more trusted than code that’s trying to run from wherever).

One way to test the copy/paste stuff is to see if each version can copy/paste to itself across a restart. This might clearly confirm the behavior you describe where your 2.79 can’t paste to itself. So start one of your Blender versions, Create a Torus or whatever, select and “copy” it. Then exit that Blender and restart it (the same version), and now try to do a “paste” and see if it works. Then try the same series of operations with the other program (use a different object type so you can tell where it’s coming from if the paste works).

I believe the copy/paste works by storing the copied data in a permanent file in the temp directory, so the above test will tell you whether each version is being able to successfully write to this file and then later open and read it. If it works with one and fails with the other, then you’ve narrowed the problem down and just need to focus on why that version is failing. If it works with both then it must be some other issue.

1 Like

Hmmm, that’s strange.
This is my blender set up:
-2.79 and 2.80 is not installed, I use only zip versions.
-Both are in the “Blender Foundation” folder in C:\Program Files
-Temp used is in my C:\Users\UserName\AppData\Local\Temp (default for zip version)
-OS is Win7Pro 64bit

If Pixelfox’s suggestions does not work, you might try the setup I am using.
What OS are you using? Reason I ask is that on Win10, there may be some funky security snafu going on, running an app on separate drives/partitions.
Just guessing here.
If your using the MSI installer, I would seriously consider not doing that any more, I stopped installing blender years ago, solved lots of issues. I only download zipped versions now. Just a thought.
Hope this helps.

1 Like

Thank you guys. I will try everything you mentioned in a win 10 laptop environment. My main machine is using win7 x64 sp1 at the moment. Scheduled a Win10 upgrade after May.