I updated Ubuntu and blender nolonger works


(B_D_W_S) #1

so I updated to the latest Ubuntu and when I start blender the display starts strobing , thats the the only way I can think of to describe whats going on .
I had a similar problem when I updated blender a while ago so I uninstalled and reinstalled it and it was working fine , but this time that didn’t work. And I also removed my ppa. any help would be really helpful ,thanks .


(rbx775) #2

Just for a bit of troubleshooting, did you try launching it with ./blender-softwaregl from the terminal ?
I mean it sounds like somethings up with your drivers…


(English is not my native language) #3

Please, provide Ubuntu and Blender version, your graphic card model and graphics driver version.
You can indicate what you get in the terminal with this command:

lspci | grep -iE 'vga|3D'

and this:

lshw -c video

(B_D_W_S) #4

This is for my laptop so it only has integrated graphics for an MAD A 8 .
When I tried to launch form the terminal it said “not found”.
The ubuntu version is , ubuntu 17.10 . And I tried blender 2.78 and 2.79 .
I entered the Ispci | grep-iE’vga|3d’ and Ishw-c video code and nothing came up .

I tried installing blender form the ubuntu software center, but i could not find any more so I downloaded directly from blender .org .
Thank you both so much , I’m for sorry for not being more clear I’m not very good with these things .


(B_D_W_S) #5

That was supposed to say AMD A8 , auto correct.


(English is not my native language) #6

You open the terminal and with Internet connection available, you execute each of the following commands (watch for error messages and copy them here):

sudo apt-get update
sudo apt-get -f install
sudo dpkg --configure -a
sudo apt-get install xserver-xorg-video-ati xserver-xorg-video-amdgpu libgl1-mesa-glx libgl1-mesa-dri

Reboot the machine.


(B_D_W_S) #7

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package xserver-xorg-videoamdgpu

That’s what I got .
And I really appreciate the help


(English is not my native language) #8

You just select text with the mouse, copy and paste in the terminal. To paste in the terminal you can use the right mouse button menu. You see that a dash symbol is missing between ‘video’ and ‘amdgpu’


(B_D_W_S) #9

I looked into the divers myself after you guys said that was the problem,
one was turned off so I turned it back on . Un and reinstalled blender and I got 2.78 working! Thanks so much help I would not have figured out without you guys !


(brainsick) #10

I registered just to say that I was having the same problem on Ubuntu 17.10 x64 with Blender v2.78c. I fixed it by going to:

Menu: File -> User Preferences
Tab: System
Window Draw Method: Tripple Buffer

Save User Settings and restart.