ICP alignment addon issue

Hi Guys,

I found a great add-on for iterative closest point alignment, but unable to make it work (under linux at the moment) Any ideas what the issue could be? Tried both 2.8 and 2.79.

Found a youtube video on how to use it, but it’s erroring out when I try to add alignment points (sorry, can’t paste the error, I’m at work and we use external VDI for internet)

I decided to put it in this topic since it looks like a great addon many could be interested in and I haven’t seen it posted before, but feel free to move the topic if it’s better off as a support thread.