I'm migrating from another platform and my files too :) need advices

Hi to all,
I’m a lightwave user and In these years I’ve created a quite big library of objects.
A lot of objects are UVmapped, complete of their textures of course.
Which format do you advice me to convert them? obj or fbx?
Thanks in advance for any help / advice.
Have a great day all of you!
Arian

You can import the LWO files directly into Blender (along with the sub-d’s if they are present). If you have rigged objects then you will obviously have to convert those or re-rig them in Blender.

I used LW for years as well, but the lack of meaningful updates and the fact that Blender has far surpassed it IMO made the decision to switch very easy. I don’t regret it one bit.

Hi Safetyman,
Thanks a lot for the reply and Thanks for the infos!
I’m in the same position…i LOVE lightwave but i need some function which are not still implemented on it…I’ll continue to use it but i want and need to learn another platform and I’ve choosen Blender…it seems really a complete and well done package and it is free!!!
Blender I think is the best choice right now…it seems really mature and powerful…I;m learning it with pleasure :slight_smile:

To import the LWO files, what the workflow is? How you import them?
With subd too?
Even the textures?
Thanks a ton
Have a great day and please, forgive me about my poor english
Arian

Thanks a lot for the infos!
How do you import low files into blender? directly?
Thanks
Arian

Founded :slight_smile:
Inside the import/export option…I’ve enabled the low import setting :slight_smile:
Thanks again :slight_smile:
Blender really rocks!

I switched from Lightwave to Blender as well years ago. I had trouble to import my LWO objects properly, until, after much testing, trial, and effort, I came up with a smooth import workflow.

The built-in LWO importer is only semi-useful. Remove it, and download the one here:
https://blenderartists.org/forum/showthread.php?336749-The-LWO-import-export-project&highlight=lightwave+importer
I’ve tested this (more up to date) importer quite a bit back when the developer still actively worked on that version.

You may have to remove the older version both in the scripts/addons folder and the one in C:\users\yourname\AppData\Roaming\Blender Foundation\2.79\scripts\addons\

Next, install the Blender Internal to Cycles material converter:

Finally, download and install Accutrans: http://www.micromouse.ca/
Support this guy by purchasing a license. It is only $20, and it’s saved my hide more times than I can remember.
(I presume you work on Windows, right? I hope so. Accutrans is essential. Install a virtual machine otherwise.)

For this example, we are downloading Millenium Falcon model found here:
http://www.scifi3d.com/list.asp?intGenreID=10&intCatID=10

Download the Millenium Falcon (YT1300) version 3 LW 8.x (23.97mb) version. It is fully textured, and includes other materials, such as an emission shader for the engines.
When you attempt to load this model, it will probably fail in Blender (it did for me, even with the updated lwo importer).

Here’s my current workflow:

  • open the Falcon folder, and move the images folder to the objects folder.
  • open Accutrans, and drag the Falcon LWO object into the view of Accutrans. It will take a while to open.
  • Optional step: fix normals in Accutrans, etc.
  • Save as LWO (Huge Objects) in the same folder. Name it Falcon2.lwo
  • Optional step: use Save As (with Options) to control which layers you want to specifically export.

Notice that the new version is more optimized (smaller file size). Nowadays I always open lwo objects in Accutrans first, and save them. Then I open these in Blender with the alternate LWO importer addon.

  • Open Blender, and use the File–>Import–>Lightwave importer to import the falcon2.lwo file. Turn off the SubD option for now.

This will take a while, and the end result is a Blender Internal compatible textured model. It will not render correctly in Cycles.

  • Notice how all the normals look a bit odd. Keep the selection (or hit A again to select all imported objects), and open the Tool Shelf (T). Under the Tools tab–>Shading: click Flat.

Sub-d surfaces and other rounded surfaces may look polygonal at this point. Don’t worry about it for now.

  • (Skip this step if you want to render in Blender Internal only.)
    Switch to the Materials tab in the properties panel. Scroll down: you should have a Convert BI Materials to Cycles panel near the bottom of the materials tab. Click the Convert All to Cycles button.

At this point Blender switches to Cycles, and you will have a fully textured Falcon model. Add some lighting/environment HDR to light it. Notice that the engines at the back retained their emission setup.

  • Finally, you will have to fix some things:
    [LIST=1]

  • enter edit mode to select rounded surface polygons (such as the turret mount), and apply a phong/smooth shading (tool shelf–>Shading/UV tab–>Faces. You may have to select edges and apply sharp shading to those.

  • fix any normal issues. (same panel: recalculate, etc.)

  • select objects that require a sub-d modifier. Select an object, and hit ctrl-1/2/3/4 depending on the sub-d level you require. Check the sub-d modifier panel for additional settings.

  • after applying sub-d modifiers, you may have to fix certain edges in order to keep a sharper edge. Enter edit mode, select those edges that require this, and open the properties panel (N). Use the Mean Crease slider to adjust these edges.

  • Fix other stuff. Materials may not be exactly the same, of course. Sometimes, after applying a sub-d, holes will appear in that part - you will have to stitch the polys.

  • Improve the look of the materials: use the principled shader to replace the old Diffuse BSDF. And so on.
    [/LIST]

Hope this helps you making the switch to Blender a bit easier.

Oh yeah, before I forget: if you ever miss the Modeler<->Layout separation, select an object (or multiple ones), and hit the / key on the numpad. This isolates the selected object(s), and feels similar to working in Modeler :stuck_out_tongue_winking_eye:
Hit that key once more to return to the scene you are working on.

Happy Blending!

Wow!
Thanks a lot for this detailed answer!!! :slight_smile:
I mean it, THANKS :slight_smile: I really appreciate it and I’ll try it for sure :slight_smile:
Have a great day and happy blending to you too!
:slight_smile: