Image added in UV Editor doesn't show up on Render


I’ve been puzzling over this for several hours. I create a cube, switch to UV Face Select mode, pick a face, open the UV Editor on another window, open an image using Image / Open… image appears on the UV editor and 3d view but it doesn’t show up on the Render. I’ve tried changing a few settings in Object / Edit mode on the cube like Materials and such but nothing seems to work.

Any ideas? what am i doing wrong?


p.s. as soon as i exit UV Face Select mode in the 3d window and go into Object mode the images don’t show on the cube again, just as they don’t show in Render.

there are 2 ways to add an texture (image) to an object

you can add a material > then add the texture to the material
(you will need to tell blender how to display the texture eg, using UV layout, orco or whatever)


you can add the texture to the object in the UV editor
(this will only display in the game engine without changing a few settings)

So it sounds like you have added your texture the 2nd way

to fix it add a material to the object (and since you already have added the image to the UV editor) click the TexFace button and it should show up in your renders

but either way you choose, you need to tell blender how you want it to effect the object

Hi Waylow,

That’s exactly it. i just hit it. I hadn’t assigned a material to that object. I was wondering why there didn’t seem to be a UV Face button or a ‘Material’ tab … it was doing my head in, then it then i compared that object to another object that did render an uv image i’d set, and realised that had a material set.

Thanks though for that Waylow. :slight_smile: