Import Rhinoceros 3D files: import_3dm v0.0.4 released


I’ve released v0.0.4 of the import_3dm add-on

  • improved material handling (but still pretty basic material conversion - full material conversion still WIP)
  • automatic dependency installation on Windows (pip and rhino3dm modules)

Big thanks to @stompintom for his work in this release.


Hi jesterKing,
thanks a lot for your work!
I have a problem here, i’ve installed the v.0.0.4 version (so no manual dependency installation), but the 3dm importer is not showing in the menu, and the other importers (except few of those) are disappeared (blender 2.80)…see pics attached

Thank you

Nevermind, using Load Factory Settings (altough it resetted my preferences) solved the problem! :slight_smile:

Happy blendering and rhinoing (:

1 Like

With moi3d opennurbs, isn’t 3dm compatible?
I tried to import an object and it is zero geometry …
Am I doing something wrong? :thinking:

MoI needs to write the render meshes like Rhino does. For now that is a requirement.

At some point I’ll add some Rhino Compute capabilities, meaning one can utilize the Rhino geometry kernel to import a 3dm that does not contain the render meshes.

1 Like

of the type that blender would see the format “rhino” native object rendering?

But I didn’t understand, so what does the addon do?
a mesh conversion, of course, but why isn’t moi 3dm okay?

The add-on reads the render mesh data from the geometry in 3dm files. The rhino3dm Python module is essentially a wrapper OpenNURBS. We do have access to the native Rhino geometry as well, but writing code to tessellate mesh surfaces from the native Rhino surfaces is outside the scope of this importer.

Rhino writes the render meshes to the file if at runtime those were created. That means that you need to switch to Rendered mode before saving the 3dm.

If you need to import files from MoI then at present you need to load the file in Rhino, ensure render meshes are created (change to Rendered view) and save.

The Rhino Compute technology I referred to means querying a Rhino Compute server (either a locally running version, or a hosted one) for those render meshes for the given Rhino geometry.

I have somewhere some very experimental surfacing tools where this technology is used.

1 Like

thanks for the explanation

Hi Jester,

Your add-on sounds great but I can’t get it to work (windows, blender 2.80)
Wich asset files do I have to download? All? Or just

I’ve got a 3dm file to be opened, hope you can help me out.

Hi Foppe3D,
i’m also on windows, blender 2.80.
I’ve installed ONLY and it works!
Bare in mind that, if you are using the filter addons option in the workspace/tool menu, the import menu would be restricted to only alembic and collada; so in this case just turn it off and you will find 3dm import (along with the other options) on file/import menu.

Thank you, Ciro, for your quick response.
I gave it a few other attempts, but this error keeps occuring:

It seems I miss a module ‘pip’? Does that says anything to you?
Hope so.

Hey @Foppe3D that is probably because pip is being installed to a location you need elevated user to do.

You could try running Blender as that elevated user, and once it is installed restart Blender as a normal user.

Note that I just now released v0.0.5 - it may be able to install pip as a regular user (fingers crossed!).


As Mac user I followed pip installation (seems to be succesful), but when I try to enable addon it starts to installing rhyno3dm dependences, but installation fails = addon popup with some error.

Any advice or experience with this issue?

All terminal logs with descriptions can be seen here
Thank you for help.

At installation on Linux, as soon as you check it, it starts downloading and compiling some additional code which takes quite some time. The console says something about building wheel for rhino3dm ( IMHO the user should be asked before this starts. Feels like someone reaches in your pocket.

Installing collected packages: rhino3dm
Successfully installed rhino3dm-0.14.0
Traceback (most recent call last):
File “/home/howarddm/.config/blender/2.91/scripts/addons/import_3dm/”, line 115, in
import rhino3dm as r3d
ModuleNotFoundError: No module named ‘rhino3dm’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/share/blender/2.91/scripts/modules/”, line 351, in enable
mod = import(module_name)
File “/home/howarddm/.config/blender/2.91/scripts/addons/import_3dm/”, line 43, in
from .read3dm import read_3dm
File “/home/howarddm/.config/blender/2.91/scripts/addons/import_3dm/”, line 123, in
raise Exception(“Please restart Blender.”)
Exception: Please restart Blender.


OK…on an import from Rhino 5, it does not import UV data. I have tried several things and it fails.
Does it not work for Rhino 5 files? As they do have UV’s in Rhino.

Using the latest version and Blender 2.83 LTS.

This sounds like the rhino3dm module failed to compile on Linux.

Are you able to pip3 install rhino3dm without problem?

At the moment there is no UV import at all.

I’d appreciate it if people asked questions over at , where I am much more active :slight_smile:

Not using Linux…Win10…
And yes was able to install without a hitch…have the older version installed in 2.80…and it works fine…may have to import there and save to import in 2.83LTS…

Where on Discourse? In general Rhino for windows?

First part of my answer was to @3D-Penguin (:

On discourse just main Rhino category or no category. Mods can always move. You can at-mention ‘nathanletwory’, that is me.

1 Like

Thank You, no i did not try to pip that. And i do not have Rhino. Importer would have been rarely used.
I was just curious, consider that solved.