import STL file into Blender

I have an STL file which came along with two ASC files, and I’m able to open this STL file in MeshLab and view the 3D model, but I don’t know how to open it in Blender.
How can I import that file?

Tom K.

try this script here.

How do I use scripts? I’m very new to Blender…

Thanks! I’ll look it up! :slight_smile:

I managed to install the script, but when I choose my file nothing happens beside this info:
What should I do now? (I’m sure that the file is working since I was able to see it in MeshLab)

in Blender there is a text editor.
use this to open the script.
then press Alt/p to run the script.

do also a search for .blender.
it may be hidden in appdata folder. (windows)

Thanks I already found the .bender folder, but now I have another problem as you can see from above. Why do I have to use the text editor if I can see the script in the scripts’ menu under Import.
After I click on it (the stl Batch), I get this screen:
I choose the folder where my stl and asc files are found (which is C: ) and I click import, but nothing happens beside what I showed in the upper picture. I also tried with the ASCII option, but it still didn’t work.
What should I do now?

By the way, my version of Blender is 2.48a (I think that’s the latest)

ok, a few tests later.
Create a folder on you hard drive. ‘my_stl_name’ or whatever.
Place your stl file inside this folder.
In the script,
press select to browse to your ‘my_stl_name’ folder.
import the file.
note, large files (2meg+) produced memory errors.
smaller files imported correctly.
batch import worked with 5 files. (pieces of 1 larger model)
Although it did seem to place all the models in the same location.
good luck!

I created a new folder and put my files inside it (you can also see their size):

When I first tried to import without ASCII option, I received this error message:

After choosing the ASCII option, I received this message:
But when I return to 3D View, I still see the default cube which I get each time that I open Blender, and I can’t see my file (the dental shape).
What should I do now?

it looks like it imported the file.
delete the default cube to see if the model is hidden by it.
the imported model should be on layer 1.
to help further,
i would need the actual file(s) you are trying to import.
if they are private, you could pm me a link so i can test.
Also what program are you using to save the stl file?
are there settings in the save stl that could affect the import to blender?
or can you open the .stl in another program & export it as something else?
good luck.

Meta-Androcto, I really appreciate your patient and help. After deleting the cube, I get this round model, which is not how my model looks like:
(When I render the frame it just shows a blue screen)

The STL file was created from a DCM file, which is a file that a 3D scanner produces.
The files are not private, you can download them as a ZIP file here:
(If you want, I can upload later the DCM files)
I’m not sure about the saving parameters of the DCM–>STL but as I mentioned before, I can view my model if I open the STL file on MeshLab.

good news & bad.
I used this program;
to open your stl file, then I saved the stl file again & opened in blender.
then testing the new program i exported then imported the teeth as
.wrl, .obj, .dae, .3ds.
however, the mesh is not a complete filled mesh.
i have come across this problem before.
more a point cloud of mesh, instead of a solid model.
you may need to change some settings or search the forum for the answer.

As I understand, this is the way of scanning - by creating this points cloud, so there is no solid model (although I wish it would be. Is there a way to do so?).
I also managed to save the the STL as other types of files and import them into Blender.
Now comes the hard part (for me :slight_smile: ) : What I would like to do is actually separate the teeth (that each tooth will become an independent model), and to move it in space (like “before and after” orthodontic therapy). I guess I would first need to convert in some way the points clouds into an actual form, right? How can I make this teeth separation?

By the way, should I post another post? Because I understand it’s not related anymore to the STL conversion. And perhaps a last question about that: Is there a free program like AccuTrans 3D that I can use to convert my STL files?

Sorry that I bump it (I hope it’s allowed), but I would be really happy if anyone could answer my questions! Thanks!